Why won't the USB 3.0 I/O card read my Seagate external HD connected to my laptop??


#21

Hi Jurgen,
Thanks for posting and sorry for the late reply - it seems that the WD 1TB My Passport is a USB-powered drive - have you connected the 5v Molex cable to your power supply?

Generally you don’t need that with brick-powered external hard drives, but you probably do with USB powered ones.

Regards,
Lampros


#22

Hi Nick,
Are you seeing the same issue with Jurgen? i.e. the device disappears from the Device Manager ?

* Is your drive USB powered or comes with it’s own power brick ?
* What happens when you connect the Passport to the card ? Any error messages?

Regards,
Lampros


#23

Hi Lampros,

My drive is using the USB cable to gets it’s power.
With the card there is a sort of power cable, which I need to attach to the card and into another USB port of my laptop, but still doesn’t work.

Are you talking about a serparate power supply ?
But I cannot use that because there is no other connector present on my WD 1TB My Passport drive.

Still I can’t use the express card, do you have any other tips or new drivers available?

Regards,

Jurgen


#24

Hi Jurgen, just so we’re not confused, are you using our ExpressCard (Laptop) adapter, or PCI Express (Desktop Internal slot) card? Can you say what the model #?

Each has its own way of getting powered (the desktop card with a molex or sata power connector from the motherboard; the expresscard via the supplemental usb 2.0 power cable).

Thanks!
Bernie


#25

Hi - I am having the same kind of problems with a wD My Passport 3.0 500 gig Drive:

  1. The drive loses USB connectivity after starting a copy job at high speed
  2. Device Manager shows that port gets disabled because it ‘stopped working correctly’
  3. Western Digital has verified via tests, software and thorough review that drive is fine.
  4. Drive works in all 2.0 usb slots
  5. Card is plugged into 5v connector

This is a problem with the Pluggable Card. I can initially copy and paste individual files and folders, but sooner or later the USB Passport Drive loses connection. Then when I try to delete a folder or file I am staring at, I get the message “The File Cannot be Found”

Please advise. Now looking at buying someone else’s board…


#26

Hi Texazman,

Thanks for posting. Since you have the 5V Molex/SATA power cable included with our card connected, your issue may be different from others on this thread (unfortunately this thread has gotten messy - the posts span Plugable and non-Plugable products).

Let’s try to figure out what’s going on in your case.

The first thing we’d recommend is upgrading to the latest drivers for the Renesas Chipset (which is used in our card and the majority of the market to date).

You can download the latest Renesas version 2.1.19.0 driver for our card at https://s3.amazonaws.com/plugable/bin…

Can you let us know if the latest drivers produce any different result, and what you’re seeing?

Thanks for your patience!
Bernie


#27

Hi Bernie,

Thanks for the fast response - it is great to see so much interest and help on a company bulletin board. I did download the drivers already and after working my backup a different way plan to get back to seeing if I can get the Passport to work straight through.

Will let you know what I find good or bad. Also noticed some threads where Microsoft had specific I/0 problems and suggested a hotfix - I have not had time to investigate that yet:

KB Article Number(s): 975617
Language: All (Global)
Platform: ia64
Location: (http://hotfixv4.microsoft.com/Windows…)

regards,

Don Z


#28

Bernie,

Have updated the Card’s drivers (to 2.1.19.0) - nothing has changed. Large copy jobs to the Passport Drive fail with I/O problems. Have tried regular copy, Microsoft’s RichCopy 4.0, Microsoft’s SyncToy and Windows 7 Backup - all fail.

Very frustrating. On top of that, running Western Digital’s Data Lifeguard diagnostics program does not even show the Passport as physically connected. Appears in Logical Drive window, but not as connected. I do see the drive in Windows Explorer but Win7 sees no files on the drive.

Device manager shows following with a caution sign on the port after I/O request fails: “Windows has stopped this device because it has reported problems. (Code 43)”

Passport works fine on XP laptop and in any 2.0 USB port. Please advise next steps.

Thanks!

Don Z


#29

Hi Don,

Thanks for the updated info! With the updated drivers, but getting a code 43, we have to check the possibility of a problem with that unit.

If you can email your Amazon order number to support@plugable.com (and mention/link to this thread), we’ll get a pre-tested card out to you right away, to rule in or out any problem with the unit.

Thanks again for your patience while we get this figured out!
Bernie


#30

Hi Bernie,

No Love in Dallas. I installed the new card, powered into a 5v Molex and even have a brand new Western Digital Passport 500GB (same model as my previous one) and now the USB 3.0 Card will not even acknowledge the drive, even after a reboot. Yet on any of my USB 2.0 ports both Passports work fine.

My system is built around an Asus Rampage Gene II motherboard with an I5 chip. Installed the new driver and am going to uninstall, reinstall drivers to see if that takes hold. I know something simple has to be going on here but so far have not been able to nail it down. Will be playing with USB HD combos and the card this weekend to see if I can resolve the issue.

Am I am no longer getting the Code 43 error - nothing is amiss in Device Manager

Will be sending the original card back to you as I work with the new one.

Thanks

Don Z


#31

Hi Don,

Thanks so much for the update! Please keep both cards for now, until the source of the problem is clear (may help isolate things to have two).

Trying some different combos is great - hopefully that will produce some useful datapoints.

By the way, I see the Asus Rampage Gene II has a number of different types of slots:
2 x PCIe 2.0 x16 support at dual x16 speed
1 x PCIe 2.0 x4
1 x PCI 2.2

We’ve heard other reports of 1x cards (like USB 3.0 cards are) not working properly in x16 slots. Have you tried the card in the x4 slot?

Thanks!
Bernie


#32

I actually have it in the x4 Slot :slight_smile: Already thought of that one. Will let you know…

regards

Don Z


#33

Hey Bernie - Success! I uninstalled the drivers, rebooted, re-installed and rebooted again and now I have the Passport recognized correctly and accepting hi-speed backup and file transfers (via Microsoft’s older utilities SyncToy and RichCopy 4.0) - both of which previously would fail.

I had done the same with the previous card as well - it appears that it was indeed defective somehow. Speed is *very* nice, as is your attention to support. Had not heard of Plugable before, but you just earned both my respect and my future money for your attention to your product.

And I buy *alot* of gadgets :slight_smile: My home office looks like a small computer warehouse.

best regards,

Don Z


#34

Wonderful! Great job getting things up and running! When you get a chance, please feel free to return the extra using the prepaid label, so we can test and diagnose.

Thanks again, and thanks for the kind words!


#35

I too am having this issue. I had recently purchased and installed the 2tb Freeagent from BB. Right out of the box i had connectivity issues. I had discovered on my clients Vostro that none of the 4 USB ports on the back would recognize the drive and only 1 of the 3 on the front would. It has been running intermittantly for the last two weeks. Occaisionally he would call me and say he can no longer access the drive. After either a computer reboot or disconnect and reconnect of the drive it would work again. As of right now i have an active light on the front of the seagate device (which only turns on when it has a good connection) but the computer does not see it nor is there an issue visable in device manager. I desperately need help. Do i have to purchase a USB 3.0 pci express card??? I too thought it was backwards compatible. I do see above a user stated he unistalled and reinstalled “the driver” which driver would that be?


#36

Hello iateawheelofcheese,

Thanks for posting your question here on our support forum. Assuming your machine has the proper slot necessary for a PCI-express card (ours requires a 1x slot) you could install an add in card for additional USB ports. However, it sounds like there are some issues with your machine and it would be best to diagnose them first before adding new hardware.

Sorry I don’t have better news for you!
Happy Holidays,
Jerome

Plugable Technologies


#37

Thanks to all the information in this thread i did solve my problem. As pointed out an express card can’t supply enough power for heavy devices like external drives. As such my drive would never show up, and just keep starting and stopping, and the card itself would keep loading and unloading from device manager.

Solution was getting a usb 3 split cable (like the Usb 2 ones), this allows you to plug the device into the Usb 3 express port with the data side of the cable, and plug the other side of the split intor an old usb2 port - to steal an extra 5 volts of power.

Plug all this together, and then reboot the laptop. that’s when everything is finally recognized. Plugged together with laptop on the drive never shows up, only the card.

Note: my NEC express card has an input port to add a 5volt power pack, but does not really expain the purpose of the port or why you would need it. No cable is supplied to use it either.


#38

Hi Mike - Thanks for letting us know! By the way, our Plugable USB 3.0 ExpressCard for laptops does include the USB 2.0 power cable that the other brand didn’t have. You can see our product at http://plugable.com/products/ecard-us…


#39

Hi There,

I found this thread with the same problem, I have.
I got an expresscard for my laptop (including the usb power cable) and I also got 2 sata2usb3 connectors inclusive power supply and two seagate sata harddisks.
When I connect one drive by the connector and power supply with an usb2 port of my laptop, the drive is found and the connection works as usual.
Connecting the drive with one of the 2 usb3 ports of the expresscard the accoustic signal for the connection occurres but that’s all. The drive management in system properties menu also seems not to work at this moment.
When I disconnect the drive, the drive management wakes up again and windows asks to format the found drive. Trying to format the drive won’t work, of course the drive is already disconnected.

I have no Idea what’s the cause for the problem. I tested both connectors with both drives. Power supply is plugged in for each drive and for the expresscard. Even all drivers are installed and the hardware manager shows no problem with any part of the hardware. The drives work fine with usb2 port and other devices like a mouse or an usb stick work fine connected to the expresscard.

I’m looking forward for a little help.

BR GrandmaTi


#40

Hi GrandmaTi,

Thanks for posting your question here. We’ll be happy to help. Can you say a bit more about your setup?

First, I’m wondering what make and model of laptop you have.

Next, try connecting a drive to the ExpressCard with a USB 2.0 cable (a drive and cable combination that worked with an on-board USB 2.0 port) and see if it works.

Then, reboot the machine while leaving everything connected and see if the drive is detected.

With the ExpressCard it’s sometimes necessary to reboot after plugging in a USB cable to the card because the spring loaded connection can become unsable and need to be reset.

If you can check these things out for me and reply back with your laptop make and model as well as your Amazon Order Id to support@plugable.com, we’ll figure our next steps.

Thanks,
Jerome.