USB Gigabit Ethernet Adapter does not work in OS X. HELP.


#1

Plugable USB 2.0 to Gigabit Ethernet will not work with my new MACBOOK PRO 17 OS X 10.6.6. But will work inside a VMware Windows 7 VM on same machine. Must be a problem with the driver for OS X. I have downloaded the latest driver from ASIX website and still no luck getting OS X to connect to any network. Please help. We may purchase a dozen more of these if I can get them to work with OS X. If not, then I must return this unit but prefer not to. THX, CJ


#2

Hi Clint,

Just to confirm, because I think I assumed to much: at what point are you having a problem (during driver install or after), and which driver are you installing (from http://plugable.com/support/drivers/ or from CD, etc.)

Thanks for this additional info!


#3

At any point, os x does not recognize the adapter. I followed your link on plugablr.com to the asix chipset page and download the latest driver. Install the driver and reboot as required. Then the second ethernet adapter will appear. I add the ip address and no connectivity. I tried different network with dhcp and still no connectivity. And when I say connectivity, I mean link/activity lights and not being able to ping gateways etc.


#4

Hi Clint,

Thanks for this additional detail that the install of the Mac driver goes (apparenly) fine, and the failure is later in network configuration.

With the latest ASIX drivers for OS X, it is not necessary to set a fixed IP address. So first, lets step back and make sure that when configured to rely on DHCP, that you’re getting the IP address, router, and DNS you expect.

I have DNS set to Google’s servers on my box here, but otherwise yours should look similar.

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0h5pee7FQLplWDasOWNnAf30Z8j-ZDhCJW3AKrJ_pMWlpfK6ay_xbzR4Y_9EFIfdiBd-IBHma75rlE8RMHsWTfgRmAB981M6FIk_7zy5LaNF.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/438237/mac-usb2-e1000-network-control-panel.png)

Could you post what settings you’re seeing on this same panel?

Thanks for your patience! We’ll get you up and running.
Bernie


#5

No. It will not obtain a dhcp address at all. It will not even show any kind of link light. But same cable plugged into built in nic will get dhcp. So driver seems to install. Just wont sync up with adapter. But like I said, it will pass thru to vmware/windows 7 and connect at gb speed and lights etc


#6

Two quick steps:

  1. The ASIX package has an uninstaller included. Can you do a quick uninstall/reinstall cycle? The uninstaller will open a terminal in which you’ll have to give your current (administrator) users’ login.

  2. After fresh re-install has finished, check network status again. If still failing, can you open System Profiler->Software->Extensions->AS88178 and verify that you have the 3.3.0 driver (dated 12/22) similar to

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0hFeHsSEay18j0T4smBfuRA3gsz9KRrbGQnlBfE2cyKCNjJLaH-PJfwVRNX2Me4VOIKPYlJw8M2kxh6a7HYHcJo=.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/438261/mac-usb2-e1000-asix-extension-info.png)

Thanks for double-checking these things to start and letting us know. Once we know we’re working with the correct driver version, then we can figure out what’s different about your setup.

Thanks again for your patience,
Bernie


#7

That is definately the driver version I downloaded. I will have try the uninstall again tomorrow morning. I will post the status when I finish.


#8

Ok. Finally at my workstation. The Software/extensions do not show the AX88178 driver listed. Maybe it is due to a permissions problem as the other user described. Thats why the driver doesnt get installed. Any idea exactly what they did to get theirs to work?


#9

Hi Clint - ok, great. That explains it.

So we just need to figure out why install isn’t succeeding. In the other users’ case, it was because they were using a 3rd party zip program, rather than Mac’s built-in ability to open zip folders: http://support.plugable.com/plugable/… and that was causing the proper permissions on 2 key files to be lost.

What I’d suggest to start is step back and open the ASIX install guide pdf (inside the driver .zip), run through install again, and try to post back on where things appear to go awry - particularly looking for any errors or warning messages during the process. Thanks for doing that and letting us know!

Bernie


#10

Here is what i get from the uninstallation script. I get no errors from the install process as nothing is verbose. I roboot and I only see USB Gigabit in the network configuration. Nothing else will happen. Tried DHCP and STATIC ip’s again but no link lights or connectivity.

AX88178_Macintosh_10.4_10.5_10.6_Driver_v3.4.0_Binary/AX88178_uninstall ; exit;
Password:
(kernel) Kext com.apple.driver.AppleUSBGigEthernet not found for unload request.
Failed to unload com.apple.driver.AppleUSBGigEthernet - (libkern/kext) not found.
logout

[Process completed]


#11

Hi Clint,

There’s definitely something going wrong with the install. I assume the AX88178 driver is still not showing up in the list of extensions (screenshot above). Is that still right?

So what’s happening I’m thinking is that the ASIX drivers are not getting installed, or at least are not replacing the Apple Gigabit Ethernet drivers. So the Apple driver is loading for a device that it isn’t designed to work with.

As a double-check of that, if the ASIX drivers installed successfully, they would have copied the Apple drivers (AppleUSBEthernet.kext and AppleUSBGigEthernet.kext) to the /asix_temp folder of your root drive. I assume that /asix_temp folder isn’t there. Is that correct?

Did you use the Mac’s own folder utility to extract the driver .zip, or a 3rd party utility?

Thanks for your patience! We’ll get the cause of the failed install figured out.

Bernie


#12

It did create the asix_temp folder. The Apple driver was/is copied into that folder. However, still no asix driver listed in the software extensions profile. I did use the default mac extractor for the driver/zip files. And again, i removed and reinstalled a few more times and no luck. But it does still work great inside my Windows 7 VM. But I still need it fixed and working in os x for myself and for the sake of others whom do not use VM’s.


#13

Hi Clint - it sounds like the driver is installed, that’s good. So let’s figure out why the extension isn’t loading.

The extension will only show up in system profiler when both the driver is installed and the USB device is present (and system profiler is closed/restarted or refreshed, if anything has changed)

You’re running VMware, and have tested assigning the USB adapter to a VM running Windows 7 and it’s fine there (which is great, because we know the hardware is good).

One quick check, though: When a USB device is assigned to a VMware VM, VMware de-enumerates that device from the host OS, in order to have the guest OS fully own it. The host OS no longer sees the hardware at all.

When you’re checking for the AX88178 extension in system profiler, can you double check to make sure no VMware VM has taken ownership of the 88178 device?

If that seems fine, but you’re still not getting network access over USB, can you go to System Profiler to Hardware->USB and do you see the AX88178 device there?

Thanks!
Bernie


#14

Yes, I had no VM’s or VMFusion running and I still was Not able to view the driver extension. Fresh boot of OS X. Fresh re-move/re-install of driver and nothing.


#15

Hi Clint - Is your Mac running with a 64-bit kernel? http://support.apple.com/kb/HT4287

Thanks for your patience in running through these questions until we find the problem!


#16

Yes, it is running 64-bit kernel. and it is @ build 10.6.5 Intel i7 w/8gb ram.


#17

Can you reboot with 32-bit kernel (hold down “3” and “2” keys at boot - more info at http://support.apple.com/kb/ht3773) and confirm if the adapter works as expected?


#18

I have battled with getting USB Ethernet to work for a while. I have tried the D-Link DUB E100 adapter, Apple’s 10/100 adapter, and the Plugable 10/100/1000.
I had similar problems and it took me a week to find the solution for my particular problem, thought I wanted to share it.
A while ago I had tried the AX8817x driver from sustworks.com and forgot to uninstall it. It does not reside in the IONetworksFamily.kext/Content/Plugins folder, so I didn’t see it. I got the exact same problems, no DHCP, but link. When using manual IP it showed connection, but no traffic possible. The System Profiler showed the 3.4 driver to be loaded, but I could not see the sustworks driver anywhere.
Once I removed the sustworks driver and rebooted, everything works fine right now.
If this does not fix your problem, maybe it can help some other people.

I also wanted to mention that Bernie seems to give excellent tech support.


#19

Hi Axel,

Thanks so much for posting that info! I hadn’t thought about people who might have a 3rd party driver like the one from sustworks installed alongside everything else – will definitely be on the look out for that as a source of problems. Good to know that uninstalling it solved the problem for you!

Bernie


#20

I am having the same problem. I can see the device under hardware/usb.
But I do not see the driver loaded. I have uninstalled and reinstalled may times, but no success. The device does not show in the list of available interfaces in the network preferences. I only see the Ethernet, FireWire and Airport.
Any help in getting this driver loaded is appreciated. I have verified the hardware works on a PC running XP pro.
I am trying to get these running on a pair of mac minis with OS X server 10.6.7.