USB 3.0 Hub, does not recognize USB3 (only USB2)


#1

I have the Plugable USB 3.0 7-Port Hub, located here…
http://plugable.com/products/usb3-hub…

It has problems recognizing USB3 devices. USB2 devices always work, but USB3 media is only detected if I unplug and replug in the hub itself.

I’ve tried every USB3 port on the computer, and I’ve tried a different USB cord, the results are the same. Every other device works fine plugged directly into the USB ports on the computer, but not through the HUB.

Here’s the kicker…

These issue’s are happening when connected to the USB ports on a Gigabyte GA-Z270-HD3 motherboard. (And it has the newest BIOS). The Hardware ID for its USB3 Controller is VEN_8086&PID_A2AF

However, the HUB works flawlessly when connected to the USB ports on a MSI B75A-G43 motherboard. The Hardware ID for its USB Controller is VEN_8086&DEV_1E31

In summery, this HUB combined with a USB3 device combined with a newer Intel USB3 Controller (VEN_8086&PID_A2AF) does NOT work.

Is there a method of making this HUB work with USB3 that I am not aware of?


#2

Hello Topher,

Thanks for contacting us! We’re sorry that your USB 3.0 7-Port Hub isn’t recognizing your devices reliably. I’m happy to help.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the device into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Once the program finishes running, please send the .zip log file it creates on your desktop as an email attachment to support@plugable.com. We’ll review the logs soon after receiving them and determine the next steps from there.

Thank You,

Amanda
Plugable Technologies
http://plugable.com/support


#3

I have a very similar problem - USB2 devices work fine but my USB3 hard drive doesn’t. The light on the drive turns on, indicating that it has power, but the drive is not recognized.

I’m running Fedora 25. I’ve looked at the system log and there is nothing there showing that the disk is present. The disk works fine when it is plugged directly into the USB3 port on the laptop itself.


#4

Hello Peter,

Thanks for your comment. We’re sorry to hear that you’re experiencing a similar problem. Please email us directly at support@plugable.com, and we’ll be happy to look into that with you further.

Thank You,

Amanda
Plugable Technologies


#5

I’ll do so, thanks.


#6

No problem, Peter! We’re happy to assist you.

Best,

Amanda
Plugable Technologies


#7