USB 3.0 docking station not working with surface Pro 6

USB 3.0 docking station not working with surface Pro 6

I have already tried removing all displaylink drivers, running cleaner and reinstalling driver but still no luck.
I have tested USB port on my windows surface and its working with other devices.

please advise on the solution.
i have bought - https://www.amazon.com/gp/product/B00ECDM78E/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1#customerReviews

thanks

I have tried this

https://support.plugable.com/t/usb-3-0-docking-station-not-working-with-monitors-on-surface-laptop/11558

Hi Riken,

Thank you for posting! I am sorry things are not working as expected while using your UD-3900 docking station with your Surface Pro 6 tablet and I would be happy to help.

Based on your description of the behavior, our next step is to get some additional information.

If you would, please send a direct email to support@plugable.com with ‘For ticket 333644’ in the subject line with the following information:

  1. The Amazon Order ID number for your UD-3900 purchase (required to confirm warranty status)

  2. While the dock is connected to your Surface and the displays are connected to the dock (even though not working, this is important), the output of our diagnostic utility PlugDebug --> https://plugable.com/pages/plugdebug

This information will both allow us to match things up as well as help us determine the next steps.

** Please do NOT post this information in our public forum, only provide it within your direct email **

Thank you for giving us the chance to help!

Bob
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.