UD-CAM with Frameworks 13 Intel i7-1360P

I’m attempting to use a UD-CAM with Frameworks 13 Intel i7-1360P. The UD-CAM is listed in the Framework Community Forum as being compatible. However, when connecting the Framework to UD-CAM, the dock continuously loops in a connect/disconnect cycle, and there is no video output.

Is the UD-CAM incompatible with Framework 13?

Hi Steve,

Thanks for reaching out to Plugable support! I’d be happy to help with that.

Looking at the specs for this laptop, it should support the docking station as it should have support for Thunderbolt 4.

A few things you might want to try is to disconnect. any other USB devices that you might have connected to the laptop and see if you can get the docking station along with a single display to work on its own first.

We also want to make sure that you’re using the USB-C cable that came with the original docking station to connect this with your computer.

If things do start working with you disconnecting everything but the docking station and a display, you can try connecting each USB device one at a time to see if one of those might trigger this issue again.

You may also want to inspect the cables to see if there might be any debris inside preventing a stable connection from taking place.

If you still continue on having problems, you may want to share information with us about what types of devices you are connecting through the docking station. It is most helpful if you can give the exact make and model of these devices.

Thank you for giving us a chance to help.

Richard A
Plugable Technologies

The problem occurs when the UD-CAM USB-C cable is plugged into the Framework even when no peripherals are attached to the UD-CAM. The power source for the Framework rapidly switches back and forth between the UD-CAM and the laptop battery.

The event log shows the following:

  • System

    • Provider

    [ Name] Microsoft-Windows-UserModePowerService
    [ Guid] {ce8dee0b-d539-4000-b0f8-77bed049c590}

    EventID 12

    Version 0

    Level 4

    Task 10

    Opcode 0

    Keywords 0x4000000000000000

    • TimeCreated

    [ SystemTime] 2023-08-24T17:15:38.2593038Z

    EventRecordID 54418


    • Execution

    [ ProcessID] 1820
    [ ThreadID] 22104

    Channel System

    Computer Framework

    • Security

    [ UserID] S-1-5-18

  • EventData

    ProcessPath C:\Windows\System32\WUDFHost.exe
    ProcessPid 1500
    OldSchemeGuid {381b4222-f694-41f0-9685-ff5bb260df2e}
    NewSchemeGuid {381b4222-f694-41f0-9685-ff5bb260df2e}

The UD-CAM works fine when attached to my Surface Pro 7, so I don’t think it is the cable or any peripheral connected to the UD-CAM.

Thanks in advance for your assistance.

Hi Steve,

Thanks for the update.

This is interesting, as it seems like this could be some sort of conflict with the computer or settings itself, since you mentioned that it is functioning perfectly fine on another computer that we would expect to see it work on.

I am going to do a little bit more investigating to see if we can possibly replicate this issue to try and find a solution.

We thank you in advance for your patience while we try to figure this out.

Richard A
Plugable Technologies

Thank you.

Hi Steve,

Apologies for the delay with this, but it appears that we just recently got this type of framework laptop in our office and I will be heading there tomorrow to test it with the UD-CAM to see if I can replicate the issue.

I have been trying to keep track of the resources you provided, but it doesn’t seem that there has been any traction with the specific type of issue that you mentioned in those threads.

Hopefully my testing tomorrow will help determine if this is a problem with the host computer or the docking station in some previously unknown. compatibility issue.

Thanks again for your patience and giving us a chance to help.

Richard A
Plugable Technologies

I am doing some testing and wanted to get a bit more info.

Could you let us know the Make and Model of the display you are connecting to the UD-CAM?

The reason I ask is because I seem to only be able to replicate this issue some displays while others seem to have no issue.

Thank you for the info.

Richard A
Plugable Technologies

I do have an update with further testing and have had consistent success with swapping out the included USB-C host cable with a Thunderbolt 3 cable.

Once connected this made disconnect two or three times, but seems to stabilize after that in all the testing that I’ve done.

At this point, this is the fix that I would recommend trying to see if that works for you as well.

Richard A
Plugable Technologies

Thank you for your feedback.

I have tried several solutions, but I have yet to be successful.

Did the connection go through a connect/disconnect cycle each time it was made, or did it achieve a stable state for future connections? For me, the connection never stabilizes but continually cycles through connect/disconnect.

What cable type is included with the UD-CAM? If the included cable is not a Thunderbolt 3 cable, what cable was successful for you? What is the brand and model?

When connecting the UD-CAM to the Framework laptop, did you have the cable connected when booting the laptop, or was the connection made after the laptop was running? I have tried both, but the result is the same.

A user in the Frameworks community suggested enabling the High-Performance power plan. I enabled the High-Performance power plan using Group Policies, but this did not resolve the problem.

I have tried the connection with no downstream peripherals connected to the UD-CAM, so the problem seems related to the power connection.

Thanks for your continued support.

FYI update. While looking around on the Plugable website, I found the Plugdebug tool. I ran the tool with the UD-CAM attached but without any downstream peripherals.

I have emailed the resulting ZIP file to support@plugable.com

Hi Steve,

Thanks for the update.

I will look out for that email with this log files but we did also do some rather extensive testing and view our own log files as well. The only consistent and viable solution that I was able to find when replicating this setup was to swap the include USB-C Alt Mode cable that comes with the UD-CAM with a Thunderbolt 3 or Thunderbolt 4 cable for connecting to the host computer.

To answer some of the the questions that you had more directly here are some additional points of information:

  • When using the Thunderbolt 3 cable I did occasionally observe an initial. two to three connect and disconnect cycles, but then it was quickly stabilized for As long as the docking station was still connected.

  • I used a Thunderbolt 3 cable to connect the docking station to the host computer and that seemed to stabilize things. The included cable that comes with the UD-CAM is a USB-C cable that supports display port Alt mode and power delivery, but not a full feature Thunderbolt cable.

  • I was able to hot plug the dock into the computer without issue, but I did also try restarting and waking the computer with the docking station plugged in and had no problem with that as well.

  • I’m not sure about the power plan fix that you mentioned, but we have seen that work with other docking stations recently.

Hopefully switching to a Thunderbolt 3 or Thunderbolt 4 table will end up fixing the issue that you’re having as well.

Thanks for working with us and giving us a chance to help.

Richard A
Plugable Technologies

Thanks for the fast reply.

Any particular recommendations for a Thunderbolt 3 or Thunderbolt 4 cable?

Hi Steve,

Here are some of the cables that I tried successfully, but really any certified Thunderbolt 3 or 4 cable should work.


Thanks again for giving us a chance to help.

Richard A
Plugable Technologies

Thanks, I ordered the Plugable Thunderbolt 3 Cable. I’ll let you know how it goes.

I purchased a Plugable Thunderbolt 3 Cable 20Gbps [https://www.amazon.com/dp/B01KGTGXQO?ref=ppx_yo2ov_dt_b_product_details&th=1] and I’ve been using it for one week.

At first, the connection worked perfectly but within a couple of days, I began the experience the same disconnect/connect cycle as with the original UD-CAM cable. The problem does not occur as frequently as with the original cable. It occurs randomly-the connection might work well for several hours, then go into a disconnect/connect cycle, then return to working okay. It’s very random. Sometimes I get the impression that it occurs when I’m using the mouse on the external monitor, as if the signal is overloading the cable.

Would a different Thunderbolt cable perform better, such as a Thunderbolt 4 cable?

Hi Steve,

Thanks for the update.

Our testing was done using a Thunderbolt 3 cable that ended up fixing the problem with a Windows based version of this laptop. You could try a Thunderbolt 4 cable but we’re unsure if that would have a different effect since the replacement of the cable with a Thunderbolt 3 version fixed the issue we were able to replicate.

It is possible that there is an element of the Linux operating system that is interfering with the normal use The stocking station.

In addition to swapping out the cable, you may try connecting directly through the USB-C port in the expansion bay on the bottom of the computer. Note that our testing with the same laptop did not result any change in our results by plugging into the USB-C module or the port in the module bey itself.

Hopefully some of this information is helpful to you.

Richard A
Plugable Technologies

Thanks for the reply.

First. I’m using Windows 11 22H2, not Linux.

I tried plugging the Thunderbolt cable directly into the expansion bay. For several hours, using an external monitor connected to the UD-CAM, everything worked without a glitch. But then I was working on live streaming a video to YouTube using OBS Studio and the connection started the same disconnect/connect cycle.

I can’t help having the impression that whenever I use an external monitor, the connection gets “overloaded” as if there’s too much data flowing through the connection.

Hi Steve,

Thanks for the update and I do apologize for the convenience confusion as I seemed to remember a mention of this computer running Ubuntu.

At this point, it may be very helpful to collect some log files from the system. to see if there’s anything there that might help us ascertain what is happening and why the fixes that we tested are not consistently working.

Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug → http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 412758’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Richard A
Plugable Technologies

I connected the UD-CAM to the system using the expansion module, as suggested. Once connected, I ran the PlugDebug utility. Fortunately (I suppose), the system went through several disconnect/connect cycles while the debug program was running, so I hope some valuable information was gathered.

I emailed the output zip file to support@plugable.com and the Amazon order number for the UD-CAM.

I want to add that I appreciate the support that I’ve received from Plugable. I’ve purchased several Plugable products over the years and have had several occasions to contact support. Your response has always been prompt and helpful.

Hi @smessick,

Appreciate you getting back to us. I’ll be jumping in for Richard who has been out of the office.

It sounds like the disconnection issue has become more intermittent – I don’t believe our testing was done over the course of several hours, so we’ll take a closer look at that to see if we end up seeing the same stability issues over time.

In the meantime, a couple of other things to consider as we try to figure out what is going wrong here:

  1. Can you try bypassing the expansion card once again, this time using the Thunderbolt 3 cable?
  2. Can you try connecting the original Framework power supply to the Framework laptop, then connecting the Plugable UD-CAM?

Thanks for all your patience with us here. I realize this has been open for over a month, so I appreciate your cooperation as we dig deeper.