UD 6950 Keyboard/mouse freeze issues


#1

Hi, I am having the exact issue outlined here


There does not appear to have been a resolution to the topic before it was closed.

My keyboard I will see the LEDs go off and come back on. If I happen to be typing when this happens it will repeat the same character a bunch of times. If I am using my mouse it will just hang.

Other devices that are connected (USB3 hard drive, ethernet, displays) do not appear to be affected.


#2

Hey Kevin, that was my original post. The only way I was able to resolve it was by adding a separate powered USB hub w/ethernet (got it from amazon for $15 or so). I now use the plugable dock for the monitors, speakers and microphone, and I use the other USB hub for ethernet, keyboard, mouse, and connecting other USB devices.

I have the plugable dock connected to the USB-C port on my laptop, and the USB hub connected to a ‘regular’ usb3 port on the laptop.

The issue isn’t limited to Plugable devices, I bought another dock from another manufacturer and got the same issue. I believe it’s with the DisplayLink chip. I went through a bunch of troubleshooting with DisplayLink directly, but they were not able to reproduce the issue.

By adding the extra powered USB hub, the keyboard issues are 100% gone. I get a very occasional flicker from the monitors, maybe once every two weeks but all the issues are infinitely better now.

Wish there was a cleaner solution than adding an extra piece of hardware, but after exhaustive tests that’s the only way I found to resolve it.

Good luck


#3

Hello Kevin, thanks for posting! And thank you, Aaron, for chiming in.

I would be happy to help investigate further and compare these two cases as they are the only reports of this behavior we have heard.

Please send our direct support email a log file from your system with everything connected at your convenience. To do so, please download and run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug and send a separate email to support@plugable.com with ‘Ticket Number 258426’ in the subject line. We’ll match everything up and determine next steps from there or we will determine if this is a similar issue to the thread you referenced.

Additionally, please include the brand and model of the keyboard and mouse you are using by replying to this thread or within the body of the email to our support email address.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#4

@Aaron_B Thanks! I will give that a shot
@wash I will send that when I get back to the office on Monday.

Thanks,
Kevin


#5

Hi. I have exactly the same issue. I purchased 3 identical Plugable UD 6950 docking stations to use with 3 identical laptops (myself + 2 work colleagues). We all experience the same laggy keyboard and mouse issue. All keyboards and mice are wired USB, but they are all different. Dell Keyboard, Microsoft keyboard, Dell mice. Plugging the keyboard and mice into the laptops directly immediately resolve the issue. Plugging directly into the docking station causes the lag. Plugging via a USB hub that’s connected via the docking station also has the same lag issue. So something definitely up with the docking station. Looking to get fairly immediately resolvement otherwise will have to return these docking stations.


#6

@mil4824, thanks for posting and sorry to hear that you are also experiencing strange keyboard lag. We’d like to gather more information to determine if this is more widespread than thought. Please download and run our PlugDebug tool (https://plugable.com/support/plugdebug/) from one of your systems that is affected and send the file that is created on the desktop by attaching it to an email to support@plugable.com. We’ll match everything up and determine next steps from there.