UD-3900 works with USB 2.0, but not USB 3.0 ports

I’ve been using my UD-3900 for about a year without issue with my Lenovo laptop and my Dell work laptop. I recently got an HP 580-023w and found when I connected it to the USB 3.0 ports that my USB devices attached to the docking station worked fine, but the monitor, audio, and ethernet did not work. With Device Manager pulled up, I could see it cycle those portions of the docking station; they’d popup, then quickly disappear. This happened when I tried connecting the docking station with each of the PC’s USB 3.0 ports. I tried reinstalling Windows (just Windows, not a fresh install), using this article, but the problem persisted. I finally tried switching to a USB 2.0 port and everything works as expected.

Any suggestions?

Hi Jason,

Thanks for posting!

Thanks for the troubleshooting you’ve already done. At this point, I’d like to request some log files from your HP computer to better investigate what could be going wrong.

Could you please keep the Plugable UD-3900 dock connected to your computer (with everything still attached), then navigate to our PlugDebug tool and follow the instructions there?

This will create a ZIP file on your Desktop containing system logs and information. Please send this file to us directly at support@plugable.com. Please include “Ticket #313936” in the subject line to match the case up to this one. Additionally, please provide the Amazon Order ID associated with the dock in the email.

Thank you for giving us a chance to help!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.