Second DisplayPort not working on UD-ULTC4K

Hi Everyone!

I’m new and I’m an happy owner of the UD-ULTC4K connected to a Lenovo X1 Carbon 6th Gen. I’m switching to a 3 monitors setup keeing the laptop lid closed. I have 2 21:9 2560x1080 monitors and 1 4K monitor.

The 4K monitor is connected to the upper DP, one 21:9 monitor is connected through HDMI Alt Mode and the other is connected through the second DP. This last monitor isn’t working, it seems to be recognized but no image is shown and keeps turning on and off. I’ve already followed the suggestions on but without success. If I switch the ports it seems that only the upper one is working (the 21:9 turns on, but the 4k dies). I have bought another cable that should arrive soon, but at this time I don’t think the problem is cable related.

Any suggestion?

Thank you!

Hello Ricky,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the device into your computer, then go to this page and follow the instructions there:

Can you also link me to what new cable you purchased? Also, currently are you still using the cable that the dock shipped with or are you using a third party cable? I only ask as some cables lack the proper connections internally to support the 4K port on our dock which relies on USB-C VESA DisplayPort Alternate Mode functionality of the host system.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies |

Hello Joshua,

thanks for the reply, how can I send you the diagnostics?

Here the link of the new cable that should arrive tomorrow

I’m using the USB C cable provided with the dock, but if you link a compatible cable I can try to swap it witha new one.

Hi Ricky,

Thanks for the information about the cable. That cable should work fine between dock and monitor. I don’t foresee any issues.

For the diagnostics, the page I linked to has instructions how to email it to us directly! If nothing turns up in the diagnostics then we may need to look into sending replacement hardware.


Hi Joshua,

I’ve just sent diagnostics using via email.

Hi Ricky!

Thanks for sending the diagnostics. We’ll take a look and be in touch ASAP with what we can find out.

Thank you!

Sorry for my delayed reply. I hadn’t realized the diagnostics you had sent were in Italian… but I was able to translate the bits of information I needed!

Looking at the diagnostics I can see there are a few things we can update and see if that helps this situation. However, overall everything looks good from a hardware perspective.

The first thing I want to do is to get the docking station DisplayLink drivers update to the latest version:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step.

  3. Download, extract and run the DisplayLink cleaner tool, found here –> and ensure it displays “Cleaning Complete”
    when done (video walk-through if you need it ->

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 9.0 M1 DisplayLink software, found here –>

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

If that doesn’t help the DP output that’s not functioning please let me know and I can make a few more recommendations.


Hi Joshua,

As I stated in my initial message, I’ve already done that procedure of cleaning and update, but without success

I know, and I hate to have you try it again - but unfortunately from what the logs show, it doesn’t appear that the cleaner successfully ran, nor did the latest version of the drivers successfully install. The logs show that currently DisplayLink Graphics Driver version 8.6.1294.0 is installed and we want to try and get up to the latest 9.0 M1.

I’d ask that you give it another try if possible!


Hi Joshua, I did everything again with new drivers, but nothing so far, the secondo displayport keeps to fail. It is recognized as a monitor connected, but it won’t turn on

Thanks for trying it again. At this point we may need to try sending you a replacement dock, though from what we know from the diagnostics this appears to be a software problem. Alternatively we may need to offer you a return for a refund.

To issue either a replacement or start a return process, please contact us directly at with the following information:

Amazon Order ID # or other proof of purchase, serial # off the bottom of the dock, and the best shipping address.


Hi Joshua,

if you can explain me what you have found in the diagnostics we can try to dig deeper if you think it is a software problem. If we still can fix it, then I’ll ask you to issue a replacement dock.

Hi Ricky,

It’s more of a lack of what we found. The diagnostic logs that I looked at most recently showed that the DisplayLink cleaner did not run successfully which is backed up by the driver version for DisplayLink that showed currently installed. I suspect that since the dock is still not working properly that the drivers were once again unable to remove properly and reinstall.

It’s possible that the dock itself could be part of the problem, but it’s hard to say for sure. If you have another computer available to test the dock with we could use that to rule out any potential hardware issues, but I know not many people have a spare compatible USB-C system for testing.

So at this point I believe sending you a replacement proactively may be the best bet here. With that said, if you’re willing to try and troubleshoot further, DisplayLink did release an updated version of their cleaner tool found here:

Perhaps this new version may be able to properly remove the old drivers so that the new drivers can finally be installed.

Best wishes,

Well, tried again even with 9.0M2 drivers, but with no luck. I gathered all information also with the DisplayLink tool, but I think it might be right proceeding with the replacement.:pensive:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.