Nexigo N660 Not working with UD 3900 Docking Station

https://support.plugable.com/t/nexigo-webcam/19706

I have the exact same problem as this thread and have followed the feedback, still to no resolution. My wireless keyboard and mouse work fine and I even replaced the USB ports they were in with the new Nexigo N660 plugin and it still didn’t work. Please advise, thanks!

Hi Christopher,

Thank you for posting! I am sorry things are not working as expected while using your Nexigo webcam in conjunction with your Plugable UD-3900 docking station and I would be happy to help.

Thank you as well for researching the issue within our support forum and the troubleshooting that you have performed as a result that is much appreciated.

The behavior you describe is not expected, so our next step is to get some additional information.

Since this additional information will include personally identifiable information, please send the following information to us directly via support@plugable.com with ‘For ticket 331115’ in the subject line. This will allow us to match things up and determine the next steps.

** Please do NOT post this information here in our public forum. Please only provide this information within your direct email to support@plugable.com **

  1. Can you please provide the Amazon Order ID number for your UD-3900 purchase?

  2. Can you please keep the dock connected to your laptop and the Nexigo webcam connected to the dock (even though not working as expected) and provide us with a PlugDebug file --> https://plugable.com/pages/plugdebug This will allow us to examine some log files from your system in order to help determine the next steps.

Apologies again for the frustration, and thank you for giving us the chance to help!

Bob

Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.