Mouse lag


#1

Good morning,

Been having lag issues with my mouse using 2 external displays…at this point I need to deal with it because it’s starting to drive me crazy. Can you help me through this issue?


#2

Hi Erik,

Thanks for posting – sorry to hear about the frustrations here.

To clarify, are you using a wireless mouse? As stated in previous topics:

We may be dealing with a RF interference issue with the USB receiver for your wireless mouse. We have a blog post that speaks to this in more detail if you are interested (https://plugable.com/2017/03/17/troubleshooting-wi-fi-performance-and-wireless-keyboard-mouse-issues-on-usb-docking-stations/).

In summary, this can often be remedied by removing the USB wireless receiver from the front USB 3.0 port and placing the receiver in one of the top-most USB 2.0 ports on the back of the dock. Does this help with the mouse issues?

Please let me know if this helps or if you are using a wired mouse.

Thanks for giving us a chance to help!

Mitchell


#3

Hey Mitchell,

I am using a wireless mouse…and initially had it plugged into a usb on my laptop that is runing the docking station. I did read some previous posts and tried to plug it into one of the top most usb 2.0 ports on the back of the dock. That did nothing. I then hooked up a wired mouse into one of top most usb ports and still had the issue. I just read your response and moved the wireless to one of the available front 3.0 ports and it may be a little better than it was previously, but it is still happening.


#4

Hi Erik,

Thanks for clearing up those details for me.

I’d like to look into the specifics of your system by requesting some log files. We have a diagnostic utility that helps us understand more about what could be going on in situations such as these. Please keep the UD-3900 dock connected to your computer (with the peripherals still attached), then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there.

The PlugDebug utility will create a ZIP file on your Desktop, which contains the system logs and information. Could you please send that file to us directly at support@plugable.com with the subject line: “Ticket #259397” ?

Thanks for your patience while we work to help!

Mitchell