Mouse Cursor Blinking


#1

All of a sudden, when my machine is using the UD-3000 docking station, the cursor blinks about every 1-2 seconds. I tried upgrading to the latest 7.9 M7 driver, but it did not work. It’s a Dell XPS 13 running Windows 10. This does not happen when the laptop is not using the docking station.


#2

Hi Allen,

Thanks for posting! Sorry to hear that you mouse cursor is blinking while our dock is connected and I will be happy to help! Based off of your description, we will want to make sure that the DisplayLink drivers are in a good state by reinstalling and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 7.9 M7 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system when prompted by the installer which will trigger the final portion of the installation

If that helps, great! If not, we’ll want to examine some log files to see if they can tell us what is happening. To help us do so please download and run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug just after the behavior has occurred so we can try and capture it. When the utility completes it will notify you a file has been created and provide our direct email support address to send the file (support@plugable.com). Please send the file to that address with ‘Ticket 146264’ in the subject line so we can match everything up as files cannot be transferred via our support forums.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3

Yeah, I tried that after I posted this and it worked. Thanks!


#4