Logitech Wired USB Headset stopped working


#1

I’ve bee using a wired USB headset with the Plugable USB 3.0 docking station for some time. I went to plug in the other day and use it but it acts as if it’s not being recognized. If I plug it into one of the USB ports on my laptop Windows will find it but if I use any of the ports on the Plugable, no dice. This may be related to the Windows 10 update that was pushed out recently but I can’t say for sure.


#2

May also be related to another post

http://support.plugable.com/plugable/…

I unplugged the Plugable and plugged it back in and the headset started working again.


#3

Hi Jason,

Thank you so much for reaching out to us, I am sorry to hear that you ran into this issue, but I am glad that you were able to utilize our other forums in order to find the solution!

If you run into any other problems, or have any questions or concerns, do not hesitate to reach out to us directly at support@plugable.com, and we would be more than happy to assist!

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#4

I found out it’s not actually working. When I unplugged and plugged back in the light on the headset came on and I assumed it was working, however, when I tried using it, it still wasn’t being recongnized.


#5

Hi Jason,

Thank you for the update about this. Marc isn’t available today, but he should be in tomorrow to continue helping with this.

David
Plugable Support


#6

Hi Jason,

Thank you so much for reaching back out to us. I am sorry to hear that the headset stopped working again, but I would be more than happy to help!

The first thing I want to do is attempt to review all of the information regarding drivers and software associated with the hub. When you have a moment, could you please head to www.plugable.com/support/plugdebug and run our PlugDebug application? Once it completes, a .zip file will be created, and then could you attach this .zip file to an email, and send it over to support@plugable.com, with “Ticket no. 201722” in the subject line?

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#7

Hi,
I am unable to use my Plantronics C320-M USB Headset (earphones + microphone) in the front USB 3.0 ports on the Plugable UD-3900 that is connected to my Thinkpad T470 running Win-10 enterprise.
A USB storage dongle is also not recognized in the front ports.
FYI: The headset works perfectly when plugged into the PC. UD-3900 is plugged into the ThinkPad Ultra Dock.

Please advise.
Thanks.


#8