Issues with Ethernet

I am using this dock with a Macbook 16. Love it and generally everything looks great. When I connect this device to my network (connects to a NestWifi Router via a Netgear switch) internet works for a bit but then the Nest looses connectivity to the internet and all devices go offline. I’ve cross-posted this to the Nest community for support but I’ve pinpointed that it is this particular device causing the issue. I’ve tried different cables and have other devices connected via ethernet but only this device is causing this issue. Any suggestions on debugging this?

Hello John,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

This behavior is a known issue that is affecting some users. It’s been seen with any device using the same Ethernet chipset that our dock is using and is a problem with the built in Ethernet driver included with macOS.

What version of macOS are you running? If you’re on macOS 10.15.x Catalina, we may need to recommend an updated Ethernet driver to try.

If you’re on macOS Big Sur 11.x, we are waiting on Realtek (the Ethernet chipset manufacturer) to get us an updated driver compatible with this new OS.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies


Thank you for this response. I am on Big Sur, so take it I will have to wait. How will I know when that update is available? Will that come through an update to the OS/drivers or is there a firmware update to the dock that will need to be applied?

You’re most welcome. I’ll have to let you know when we get the driver update, I do not believe Apple will be pushing this update proactively.

We’re closely tracking this issue, so I’ll update you here the moment it’s available. But in the meantime, please don’t hesitate to let me know of other questions or concerns.

I do apologize for this issue, I know it’s quite a frustrating problem to deal with. If at all possible, we recommend falling back to WiFi to prevent the dock Ethernet from causing network failures.

Best wishes,

@Joshua_H - Do you know if Big Sur 11.1 addresses this?

Looking at the release notes from Apple, nothing in this area is mentioned:

As such, I assume it has not been addressed by Apple. We’re still waiting on an update from Realtek for Big Sur as well.

My apologies!

+1 I have this same issue with the TBT3-UDC3.

I can confirm that Big Sur 11.1 does not fix the issue.

Same here. Any thoughts on what other device paired with this is causing the problem? I thought it might be a Pixel 3a we have since there was a while everything worked okay, but with so many devices in the network it’s hard to tell!

Not sure what you’re asking, the problem is definitely the macbook, not any other device.

This is a known issue with the macOS provided Ethernet driver for the Realtek Ethernet chipset in several of our Thunderbolt 3 docks and many other docks, Ethernet adapters, etc on the market currently. We’re working with Realtek to get an updated driver to provide to our customers as soon as possible, though at this time we do not have an exact estimate when the driver development will be finished.

For now, we recommend to disable sleep and it should prevent these issues from occurring, or leave sleep enabled and use WiFi temporarily (and disconnect the Etherent cable).

Best wishes,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.