HD plugged into USB 3.0 hub disconnects after returning from sleep

Well, as of ejecting there are several solutions, at least some of them do work (I didn’t try the personally but people say they work). Among those aforementioned SleepWatcher, free ControlPlane (an overkill for the purpose IMO), a $3 Scenario from App Store. But all of them involve AppleScript and Finder and can’t distinguish between hub and direct attached volumes so they’re not perfect. What is really needed is to analyze USB chain the way Apple Sytem Info is doing and eject only relevant volumes.

But as of remounting them, the problem is they’re “not here” in the first place, that’s the original problem, they’re not visible to diskutil so there is nothing to mount. What has to be done is to force OS to rescan USB devices (it can be done SOMEHOW since in Windows one can do it programmatically). Unfortunately I don’t know OS X good enough (I’m professionally a Windows guy) so I have absolutely no idea HOW to do that.

Bernie, Jerome I received an email from apple regarding my bug report. How about if I forward it to you and you respond since you can do a much better job explaining the issue.

Sounds good, thanks!

Need the email address

Btw I have not installed the new update. Do you know if it resolves the issue? I assume not.

Hi Eric - please go ahead and email to support@plugable.com, thanks. We expect the same, but need to do more testing.

What did they say? Why can’t you just post their reply here?

And, well, I did install 10.8.2, still the same.

Who? Plugable folks will be responding to my email from apple.

Any updates?

It’s funny, if I plug an external drive directly into computer it remounts on wake.

Plugable, could this be an issue with your hub after all?

Also, this thread should not be marked solved.

Hi Eric,

Thanks for asking for an update!

We had contacted VIA (the hub chipset in this and most USB 3.0 hubs on the market right now) , to try to understand why only Macs had this issue (not Windows and Linux) and if it could be fixed or worked around at the VIA firmware level.

We’ve been assuming it’s a conflict over proper power management behavior, where Windows and Linux are more tolerant.

Sometimes that kind of thing can be worked around, sometimes not. Without having any info from Apple, it was difficult to be sure.

The problem with drives disconnecting returning from sleep is mostly when connecting through USB 3.0 hubs, but can also happen in many random cases without a hub. Here’s a good active thread with lots of detail and workarounds:

Our understanding from VIA is a workaround in firmware may be possible for at least some portion of the problem, but they haven’t been able to deliver it yet for the VL811. Also, historically their firmware update utility runs on Windows only – so it may logistically be a pain for Mac users even when it’s out.

VIA hasn’t had any publicly available firmware updates for the VL811 until this week - but there’s now one released Oct 29th (version 0972):

This one appears to have a problem where we can’t recommend it, but we’re hoping this will be the start of a series of updates that may work around or fix this Mac issue.

We’re testing each one on our USB 3.0 Macbook here, and will post here if / when there’s a workaround from the VIA side.

The workaround or fix may also come from the Apple side. 10.8.2 still has the same issue, but there are a lot of people holding out for 10.8.3 in the Apple support forums.

Hope this update helps! We’re very actively watching all the pieces here, so we can communicate a fix as soon as it’s proven.

Thanks again,

Hi everyone-

I just wanted to share some good news and let you know that the 10/29 VL-811 firmware update from Via does resolve the issue with hard drives disconnecting on sleep in our lab tests. Unfortunately the firmware update tool is Windows only- although I was able to use it on a 2012 air running Windows 7 in Boot Camp.

I’ll be posting something to our blog within the next day or two explaining the details, but please feel free to download from the following link and post back with any questions you have:


Best wishes-

Jeff Everett
MCITP Enterprise Support Tech
Plugable Technologies

The accompanying PDF says the updater works in 32-bit Windows only. Is that true? What kind of Windows 7 did you use?

Hi Andy-

I used several versions of Windows to run the utility, including both 32 and 64 bit Win 7 WITHOUT disabling UAC as suggested in PDF. I know a lot of folks don’t like UAC but I think it’s a great security mechanism.

I’m just waiting on a few more details back from Via about any other bugs that were addressed in this update before hitting publish on the blog post.

Best wishes-


For benefit of anyone finding this thread having other USB issues I also wanted to mention that while unrelated to this specific issue hard drive disconnect on sleep (in my testing), there is an Apple update for all mid-2012 Mac notebooks. I just wanted to reiterate that things are changing on both sides of the USB 3 software world- and these changes can even vary based on which particular model of PC you have. More details are in my blog post on the topic at:




Worked fine for me (update in bootcamp Win7x64 on rMBP). In ML USB3 WD My Passport wakes up successfully after sleep.

External superdrive still doesn’t work but that, I guess, would be to much to ask.

Hi Andy-

Thanks for posting back with your findings!

As to the SuperDrive: if we’re talking about the same product (this: http://store.apple.com/us/product/MD5… ) from what we can tell, the device seems to require more than the standard amount of power on a single USB port, so it winds up only working when connected directly. Sorry I can’t be more help on that particular question.

Best wishes!


Yeah, I know, but not THAT more. It APPLIES for extra 600 mA but it doesn’t really use them, not always, anyway. I tried it in bootcamp and it did work fine (didn’t try to write though, that, probably, would fail). But even with that 600 mA more it’s still just 1100 mA while USB3 port can already provide 900 mA so it would be just 200 mA extra.

Anyway, since it works in Windows the problem is with Apple. Well, kind of. I guess OS X communicates with SD it reports that it failed to negotiate for extra power. End of story. While Windows just doesn’t care. Still, nothing prevents VIA from implementing power negotiation the same way apple hardware does.

It is my understanding that the external SuperDrive has firmware that ties it to Mac’s. Its not about power.

So am I to understand that the issue has in fact been the device and not Apple?

Three plus months have passed. Many of us have spent time trying to wrangle Apple and it’s been your product all along.

I for one, don’t find this reasonable nor do I see where your company has been proactive to solve this faster.

Apple, it seems, was right in saying your product was not following the protocol.

Why are you at the mercy of via?

Also, you cannot provide a fix for apple purests so I would expect you to send out updated units and pay for the old ones’s return.

Hi Eric-

Thanks for your continued involvement and help getting to the bottom of this!

We’re more than happy to send you a replacement unit that we’ve already updated. Please feel free to verify your original amazon order ID mailing address in a mail to support@plugable.com, attention Jeff.

Should you believe another vendor has a product that will better fit your needs, we’re also more than happy to offer a refund. I’d love to be able to recommend a more trouble-free product for the benefit of the community at large, and we appreciate any input if someone is aware of one.

Please let me know how you’d like to proceed.

Best wishes-