HD plugged into USB 3.0 hub disconnects after returning from sleep


#1

I’m connecting WD My Passport 2TB USB 3.0 drive to Apple rMBP. When connected directly, everything works just fine, computer goes to sleep, wakes up, disk is still there. However, when connected via Plugable USB3-HUB4 REV.A (powered mode), after waking up computer I’m getting a message “drive wasn’t ejected properly” and it isn’t here any more.

I tried it while the drive was the only device connected to the hub and I also tried to setting the drive itself not going to sleep (using accompanying WD utility) – still the same.

According to Apple (http://support.apple.com/kb/TS3169) that could happen when:

* The third-party USB hub doesn’t support the proper USB wakeup sequence.

* The third-party USB hub is connected downline to another USB hub. Note: Apple displays containing USB ports are considered to have a hub, so if you connect a third-party hub to the display, then that USB hub is considered downline.

* The computer is woken from an external USB device such as a mouse or keyboard.

I eliminated the second and the third issues so that means the hub hub doesn’t support the proper USB wakeup sequence. So, what am I to do now?


#2

Hi Andy,

Thanks for posting your question here on our support forum, we’ll be happy to help. Can you say which OS X version you are running?

The VL 811 chipset in our USB 3.0 4 port hub does support USB sleep functions and we’ve tested it on 10.6.8 and on Windows 7 successfully. On OS 10.8 Mountain Lion it did not work and we were able to recreate the failure that you described. Here’s a link with to some others having similar problems.

Let me know which version of OS X you are running and we’ll see if there’s anything we can do to help.

Thanks,
Jerome

Plugable Technologies


#3

Yes, I’m running 10.8. And according to this:

http://plugable.com/2012/07/26/plugab…

USB3-HUB4 was “specifically tested” on Mountain Lion. I guess, the tests were not thorough enough. Anyway, since you were able to reproduce the failure, I hope you find a solution soon.

If it would be of any help, I observed the following behaviors:

  1. After waking up unplugging and then replugging the hub itself did NOT bring the disk back. But unplugging/replugging the disk from the hub did.

  2. At least in some cases if I just left everything as is, the disk would reappear some time later (a few minutes, maybe) without any intervention.


#4

Hi Andy,

Thanks for the additional details, we’ll update the 10.8 hardware listing to reflect the issue with 10.8 and the USB 3.0 hub. We’ll also do some additional testing our other hubs to see if the behavior is limited to USB 3.0 or not. Check back with the table of compatible devices for the results.

Thanks,
Jerome.

Plugable Technologies


#5

Geez, thanks! It’s really great that you’ll update the table. I guess… But are you going to do something to actually resolve the issue? Like updating firmware or providing a custom driver.


#6

Hi Andy,

It looks like the problem is on the OS side. In our testing, hard drives connected through the hub wake from sleep correctly in earlier OS X versions as well as Windows and Linux.

We’ll take a closer look at Mountain Lion and our products to better understand the situation and make sure that the table is as accurate as possible. We’ll also continue to update it with new information as it becomes available.

Hopefully there will be a fix for this bug soon, unfortunately we can’t do it with the hub firmware. Here’s a couple of links to others reporting wake from sleep issues with Mountain Lion.

http://forums.macrumors.com/archive/i…
http://www.macworld.com/article/11680…

Thanks for your patience,
Jerome

Plugable Technologies


#7

So after 15 days you have NOT updated your web site with this now KNOWN issue. I luckily used a google search to find this thread.

And what are you doing to work with Apple to resolve this problem?

I hope you’re not just waiting…you should be in contact with them as a hardware vendor to report the issue. This carries greater weight over a few users reporting an issue.

Please update us.


#8

Hi Eric - Thanks for posting! Thanks for catching that our “OSX 10.8” summary post needed updating – that’s been done now.

It’s definitely frustrating to have a Mac OS X update break something, and then not have any updates on resolution.

Just to set expectations, Apple provides no special channels for hardware makers to report issues like this. That’s frustrating for us, too.

We’ll keep trying to raise the issue, tracking it, and providing updates.

That said, we never want customers stuck waiting on a fix from Apple, when the resolution time is unknown. Refunds are easy within 30 days of purchase – just visit http://www.amazon.com/gp/css/returns/… for a no-hassle full refund for any Plugable product.

Again, my apologies that we’ve got no software involved here, so it’s not an issue we can work around. Thanks for your patience!

Bernie


#9

> Refunds are easy

Well, that’s not true. From Amazon policy:

“If you return an item using the return label provided in the Online Returns Center and the reason for return is not a result of our error, the cost of return shipping will be deducted from your refund.”

I also don’t understand why you marked this topic “solved”? Nothing whatsoever was solved, hub still doesn’t work as promised (and advertised – doesn’t it makes it fraud?)

You’re trying to blame Apple but that’s ridiculous. Not that they’re blameless, but Mountain Lion does work correctly with USB3 drives connected directly to the computer, so Apple’s hardware and software does their part. Problems occur only when your hub is in between.

Furthermore, you said you tested your hub under OS X 10.6.8 but Apple started installing USB3 ports on their products only after 10.7 was released so I don’t see how you could do it at all, never mind the reason to do that.

In other words, you made a faulty product that’s completely unusable (the only reason to buy USB3 hub is to use it with storage devices, otherwise much cheaper USB2 hubs would be sufficient) and CANNOT be returned for a FULL refund. And you plainly refuse to even TRY to fix it, refuse even ADMIT your fault and offer some workaround.

That’s definitely the last product I bought from Plugable and I’m sure ti spread the word around.


#10

Hi Andy,

I understand your frustration. If there was anything we could do, we would.

Please read Apple’s support forums on this issue, e.g.:
https://discussions.apple.com/thread/…

You’ll find lots of company on this issue, it’s nothing to do with a particular brand of hub – it’s across the board with USB 3.0 hubs, but also seems have started happening with 10.8 with some other combinations of hardware.

  1. This problem does not happen with Microsoft’s Windows 8 USB 3.0 stack (or Renesas’ … , or VIA’s …) or Linux’s USB 3.0 stack. USB 3.0 hard drives we’ve tested have no problems resuming from sleep with a USB 3.0 hub with any of these systems.

  2. This problem happens on Mac 10.8 and 10.8.1 with all brands of USB 3.0 hubs that we’re aware of. We’ve tested several. It does not universally happen with USB 2.0 hubs (I think our comment about 10.6.8 above was mistaken in the sense that it was a USB 3.0 hub on a USB 2.0 only system).

  3. This isn’t a firmware issue, it’s an issue with Apple’s USB Hub driver – and you wouldn’t want us trying to replace an operating system component. That wouldn’t work out well. :slight_smile: Apple has to fix this.

  4. Because of the wide impact, we expect Apple will fix it soon in a 10.8 update, but we can’t control their schedule. Apple doesn’t give outside hardware makers any special ability to influence their internal development teams.

Some technical background on hubs and drivers: USB Hubs don’t have their own driver (that’s why there’s never a CD or driver install needed for any standard USB hub), because the software interface to USB hubs is standardized, and driver support for hubs part of the core USB 3.0 stack (along with the host controller, etc.) provided by the operating system. So there is a driver, it’s the same one that will load for all hubs, and in the case of Mac OS X 10.8, it’s provided by Apple.

Now back to what we can do:

Even when we’re not at fault, we do stand behind our product and try to make things right. We don’t want our customers suffering for any reason.

And particularly, we never want customers stuck with hardware that won’t work for them. So please go for the refund for your Amazon order, and if Amazon (for whatever reason) doesn’t give you a full refund, including shipping, please just email your Amazon order # to support@plugable.com and we’ll cover the rest (we can look up Amazon orders to see what portion has already been refunded).

By the way, Amazon makes their stated policies a little stricter than the actual implementation (they want to exceed expectations). So you may find the shipping reimbursement is no problem in practice.

Again, I’m sorry for your frustration. I hope this provides context for why we can’t fix Apple’s problem here – it’s got to be an Apple fix.

Best wishes,
Bernie


#11

Andy, the hub worked perfectly under lion. It is a mountain lion issue.


#12

Also if you use a return reason of defective there is no return shipping charge.


#13

There is no reason to return the hub once apple fixes ML it will work very well!


#14

The very least you can do is to verify, where the problem is. Apple clearly states on its site: ‘Hubs that conform to what is commonly referred to as the “2008 version 1 USB 3.0 specification” are supported.’ That’s either true or not. And that’s what you can and should verify. Test your hub for compliance, not whether it works with some particular version of some particular OS but whether it conforms to that spec. If not, you have to fix it (or make VIA fix it – yes, by updating firmware). If is IS compliant, you should confront Apple. And in any case you should report the results of that test here, on your site. And keep you customers informed on the progress.


#15

Are you saying it based on a personal experience? I mean, you had Mac with USB3 port and Lion, this particular hub, USB3 HD, everything worked just fine – then you upgraded to ML, HD started getting ejected after sleep. Just curious.

If so, did you file bug report with Apple? You must be annoyed with this problem as much as anybody else. And I can’t file such report since I can’t verify it only started happening in ML.


#16

the answer to both of your questions is yes.


#17

Thanks, Eric. I really appreciate you did something about the problem – unlike Plugable that claims “Apple provides no special channels for hardware makers to report issues like this.”

But, unfortunately, we might still be out of luck, 10.8.1 is already out and nothing is fixed. The problem is that might be not a bug but a “feature.” USB3 hubs from, looks like, all manufacturers are indeed plagued by problems. And judging by other reports sometimes (other) hubs work OK with a single disk attached but got disconnected with 2 or more disks attached. So that might be a case of wrong timing, a hub just doesn’t do its thing fast enough. It’s quite possible Lion allowed for more time, greater than that defined in spec and ML “fixed” that. If that’s the case, Apple might be unwilling to change it back.

And here Plugable may be able to do something. First of all, protocol parameters might be controlled by some hidden options. That’s one way to fix it without completely rewriting native Apple code.

And if that’s not possible, they could provide a reasonable workaround, namely, ejecting hub attached drives before going to sleep and reattaching it after waking up. There is a very simple open source program called SleepWatcher that allows to run scripts right before going to sleep and right after waking up, they can use it as a basis for their workaround utility.


#18

Since my drives do wake properly when attached directly to the rmbp, you might be right.

Your thoughts should certainly be used by plugable to have a discussion with Apple. If Apple has changed the interface, then hub makers could be facing a firmware issue

I have not tested a USB 2.0 hub to see it if works. I do know that the USB 3.0 implementation on osx is not perfect.


#19

Btw there is an app that does eject on sleep and mount on wake. I have tried it and it does not work.

It’s called jettison

In fairness I do also have a Ethernet dongle attached to the hub and it wakes properly.


#20

Does not work to correct the issue that is…