docking station not detecting monitor


#1

I just bought one of your USB 3.0 docking stations (DisplayLink) and plugged it in. All preferrals work except for the monitor.

I unplugged the monitor from the back of my desktop PC, plugged it into the docking station, plugged the docking station into my Dell laptop (new, Precision 15R, Windows 8, 64bit), it ran through the plug-n-play and everything (mouse, keyboard, speakers, LAN) work except there’s no display. I tried the same with my Mac Book Pro and same result.

I plugged the monitor back into the back of my desktop PC and it came on with no problems.

What am I doing wrong?


#2

Hi there,

Thanks for posting your question here. Let’s first try resetting the firmware on the dock and reload the DisplayLink driver on the machine to see if that will get it into a good state. Here are the steps:

  1. Disconnect the dock from the computer and the power adapter from the dock.

  2. Run the DisplayLink Cleaner tool to completely uninstall existing DisplayLink Software:
    http://displaylink.com/techsupport_fi…

  3. Download driver v7.2 M1 from the below link and follow the installation prompts.
    http://www.displaylink.com/support/sl…

  4. Reboot the computer,

  5. Replug the power adapter to the dock and reconnect to the computer. Allow several minutes for the driver to enumerate and for the firmware to complete upgrade.

Let me know what you see after this!

Thanks,
Ellen


#3

That solution didn’t work for me. When I first got the docking station, everything worked fine. Then I ran a Dell update software that is supposed to check all of my software to see if anything needs updating. After that, the monitor stopped working in the same manner as Saeid described above. I tried the steps that Ellen recommended and they didn’t work.


#4

December 14 2016
Brand New Dell Inspiron I7 7000 Windows 10 NVIDIA GEForce 940 MX

I have spent 6.5 hours with Dell Technical support, the first go around corrupted the OS on a I5 Unit.

Dell tried to disable the Intel Graphics card, updated the NVIDIA, had me connecting through Laptop HDMI. Changed the output to equalize across monitors.Nothing.

Today hooked up new Dell USB 3 D 3100… Followed Displaylink instructions, ran cleaner, reinstalled driver… …Display Configuration shows a 3rd monitor…however No image on the 3rd monitor. I have checked cables, reconfigured and have picture on monitor that will not perform. it does work.

In fact Dell can see the display from their tools however the D3100 will not cast the image to another monitor.


#5

I have two VGA monitors and it will only recognize the one even though I bought a cable that allows me to plug both in? Why would this not detect the other. It says it is for dual monitors?


#6

Hope someone can help me out here

I have a EliteBook 8560p which is plugged into my docking station (HP 2012 230W Advanced Docking Station(A7E38AA)). I have 2 monitors plugged in 1 via DVI and 1 via VGA. Both monitors are ACER and they both work, I have confirmed individual on a another computer.

VGA works fine on both monitors and i tried switching it around same thing dvi doesn’t work.

When I plug in the DVI into the docking station the screen powers on and then goes dark the blue turn on light on the monitor flashes. The screen shows up in the display as well but I can’t access it. When I log in through team viewer I can see the 2nd screen tho.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1592692/Display_inline.png?1494041279)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1592692/Display.png?1494041279)

Just wondering what the issue could be and how can I resolve it so i can see the DVI monitor .


#7

I am having this same issue - I have tried all the steps, and no results…has anyone been able to resolve?


#8

I have the same situation too.


#9