Docking Station No Longer Working - Partially


#1

I have been using the USB 3.0 Docking Station for about 2 months and everything was going fine. I came back into work Monday morning and the monitors are now frozen on the last image that was on the screen. I have tried unplugging the docking station and monitors and it works for just a minute and then both monitors freeze back up. The mouse and keyboard attached to the docking station are still working and the screen on the monitors work perfectly when not plugged into the docking station.


#2

Hi,

Thanks for reaching out to us, I am sorry this is not working as expected.

I would like to start by fully resetting the docking station to see if this helps.

Please perform the following:

  1. Disconnect the docking station from the computer and unplug the docking station’s power supply from the wall power or power strip
  2. Disconnect the connected USB devices from the docking station, and unplug the power supply from the back of the docking station
  3. Let the docking station sit for 30-90 seconds to fully discharge
  4. Restart the computer
  5. After 30-90 seconds plug the docking station power supply back into wall power or the power strip and reconnect the docking station to the power supply
  • Please let me know if the blue power LED does not turn on the front of the docking station when connected to the power supply
  1. Reconnect the docking station to the host computer and check for the displays to be detected. If they are not detected please restart the system
  2. If the displays are detected and working normally, reconnect USB devices one at a time and verify each is working correctly before connecting the next device.

Please let me know if this helps and we can go from here.

Thank you,

Pat


#3

Thank you. That seems to have resolved the problem.


#4

About 10 minutes in it did the same thing again. Please advise.


#5

Hi,

Thanks for performing the reset, our next step is to perform a ‘clean’ installation of the required DisplayLink drivers to help ensure they are in a good state. Please perform the following:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel > Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download and run the DisplayLink Installation Cleaner utility, found here ( https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+8.4.2135.exe ) and ensure it displays “Cleaning Complete” when done (video walk-through if you need it > https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.6 M1 DisplayLink software, found here ( https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+USB+Graphics+Software+for+Windows+8.6+M1.exe )
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system. If the device is not detected, please reboot the system.

Please let us know if that helps get things working how they should, and we’ll go from there.

Pat


#6

It worked for just about 1 min and then went back to the same issue. Still not fixed.


#7

Hi,

I am sorry this is still having issues.

At this time I would like to request some log files from the system to help narrow down the cause of this behavior. I have sent an email with instructions for using our PlugDebug utility to gather the log files and email instructions for sending in the logs.

Thank you,

Pat.


#8

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.