Disappearing cursor


#1

I just got the UD-3900 hooked up to two external monitors. I have the Surface Pro 2. I have the Surface display turned off when hooked up to the dock. For some reason the mouse cursor disappears every second or two. It is exteremely unreliable. If I click the mouse button it will show up again, or if I wait it will show up randomly. I have the latest drivers installed and I’m running windows 8.1. Any idea what is going on and how to fix it?


#2

I found a workaround by doing some searching on this site. I enabled pointer trails (and set them to the shortest possible amount so I don’t notice them). For some reason the cursor does not disappear anymore. I’m going to chalk this up to an issue with the Plugable driver and the display driver on the Surface Pro 2.


#3

Thanks for self-solving! If you have a chance, could you check in “Programs and Features” and let us know which of these DisplayLink software version you’re running?

7.5.54051.0 (7.5 M1)
7.5.52889.0 (7.5 M0)

There are some power management changes from M0 to M1 which could affect cursor behavior (if the main Intel GPU goes to sleep, especially if main tablet screen is configured off)

Thanks again!
Bernie


#4

I am running 7.5 M1. I do configure the main tablet screen to be off when I have it docked to my two external displays.

Thanks!


#5

Ah, great to understand. What’s happening is the Intel GPU is going to sleep because the main tablet screen is off - and that’s affecting hardware cursor behavior.

If you can configure the tablet screen to be part of the desktop (even off to the side), that will be another way to solve the issue (as an alternative to switching to a software cursor, which pointer trails does).

Thanks!
Bernie


#6

Thanks for the explanation that is very helpful. I didn’t realize that turning on trails enabled a software based cursor vs. a hardware cursor. I’ve got no problem leaving the trails on. Setting them to the shortest setting barely makes them noticeable. I Definitely don’t want to turn on my Surface display when using it hooked up to two large monitors.

Thanks for the support!


#7

I also have a Surface Pro 2 and I am using the Plugable UD-3900 docking station to connect (a USB Mouse, USB Keyboard, USB HD, Monitor and Ethernet cable). I have a HP 2009M Monitor and I the Max Resolution of 1200 X 900 via DVI.

When I am using the Monitor I am pressing the window key + P to project to external screen only. This turns off the display but I am not sure about the Intel GPU. I thought the same thing was happening when had both the Surface Pro 2 and Monitor working together. But now I will have to double check?

I am using the Latest Drivers from the “7.5 M1 27 Feb 2014” should I use the MiniDislay Port option (I would need to purchase the adapter) or do I need a Better monitor? Any Suggestions to help resolve this is greatly appreciated.

Thanks
David


#8

Hi David - Thanks for asking.

If the screen driven by the Intel GPU (the Surface’s screen itself) is completely off, the cursor won’t render properly on any other monitors, including USB-attached ones.

In the earlier 7.5 M0 driver, DisplayLink had a workaround by keeping the Intel GPU awake at all times – but that has an impact on battery life, so the workaround was removed in 7.5 M1. 7.5 M0 is still available for download.

With the “Extended” setting (not “Projector Only”) you get the best behavior - the cursor is rendered on all screens, yet the Intel GPU can sleep and save battery when nothing is changing on the main Surface screen.

Can you say what is leading to the “projector only” mode over “extended” mode? We can try to help find the right workaround.

Thanks for your patience and best wishes,
Bernie


#9

Hello Bernie:

I am using the 2nd Monitor as my primary when docked. This way I don’t need to go between screens. It’s my understanding that Extended means you want to use more than one display at the same time.

I will try Extended mode and have the 2nd monitor display the desktop and the Surface display the titles. I will let give you update and if this has resolved the issue.

As far as connecting a second Monitor to the Plugable docking station, do monitors with HDMI Perform better then DVI with the Surface?


#10

You should be able to extend to external monitor and set surface display to off.


#11

Hi Dave - HDMI and DVI will work equally well. Let us know if the cursor problems disappear with the “Extended” configuration. We’ll do whatever we can to help. Thanks!


#12

How do you set the Surface display off? The performance is much better in extended mode.

Thanks


#13

I have resolved the issue.

  1. On the Desktop toolbar select Show Hidden Icons (white up arrow)
  2. Right Click on the Plugable UD-3900 icon to bring up the Context Menu
    3 Choose Plugable UD-3900
  3. From the sub Menu choose Notebook Monitor Off

Hope this helps.


#14

That works. I use the control panel method.
1.Control Panel
2.Display
3.Screen Resolution
4.Click the monitor you want to turn off
5.Under "Multiple displays, select “Disconnect this display”


#15

Great! Either way it works.

personally, I didn’t like Microsoft’s solution.
Use their Mini Display Adapter and their Docking station.

With the few changes suggested here Plugable does what I want

I hope this helps others who have a similar issue.


#16

Thanks for the great job writing the configuration that solved it for you!


#17

Almost Solved I have been running the Surface Pro for a couple of hours and the Cursor issue is back. Whenever I turn off the surface display off.


#18

Rather then beating myself up over this. I am leaving it on extended both displays on. when the Surface Display is off after an hour or so the Cursor seems to act up.


#19

Just to double-check, can you validate that the older DisplayLink driver solves the issue (because it keeps the Intel GPU awake at all times?)

  1. Unplug your USB docks and graphics adapters
  2. Go to “Programs and Features” and uninstall “DisplayLink Core Software”.
  3. Install the previous version 7.5 M0:
    http://displaylink.com/support/sla.ph…

If everything is fine with the 7.5 M0, we’ll know it’s the Intel sleep vs. cursor tradeoff that DisplayLink is struggling with, and we can get them feedback on it.

Thanks so much for your help!
Bernie


#20

Hi Dave - Great – that’s the foolproof solution. Thanks!