Compatibility problem

I have a strange compatibility problem with my USBC-NVME. I’m using it on numerous PCs without problems but recently I bought an ASUS VivoBook S13 and it doesn’t work at all. When I connect nothing happens for about 10-15 secs then I get an error message “D:\ is not accessible. Invalid function.” The device shows up in Device Manager correctly installed but not the disk drive. Disk Management shows the drive as D: but no partitions nor unpartitioned space is visible, that area is grey. I tried connecting with the following cables:
USB-C - USB-A (3.1 port)
USB-C - USB-A (2.0 port)

  • same results. Of course my every other USB devices work flawlessly plugged into the ASUS.

What should I try?


Thanks for reaching out to us, I am sorry this is not working as expected and I am happy to help!

The D:\ is not accessible message normally means the computer cannot detect the drive installed in the enclosure, as this only occurs on the ASUS VivoBook S13 and not on other computer is could indicate the computer is not providing enough power to the enclosure or a software fault preventing the drive detection.

Based on your description of the behavior, our first step is to get some additional information from your system to help see how the drive and enclosure are being detected.

If you would, please keep the enclosure connected (even though the drive is not being detected correctly ) and attach the output of our diagnostic utility PlugDebug ( ) to an email to ‘’ with the subject line ‘Ticket #323680 - Attention Pat’, this will let us take a look at how the computer is detecting the enclosure and will provide our next steps.

Additionally, please include the enclosure’s serial number ( from the aluminum cover ) in the reply email, some of our enclosures may have a firmware update available, the firmware update is not designed to resolve this specific issue but I would like to see if this enclosure can be updated.

Thank you,

Plugable Technology

Hi Pat,

thank you for the reply. Email sent, with the Plugdebug results and the serial.
For the time being here is some additional info.
My unit is Realtek based and I already updated the firmware.
I noticed that if I keep it connected to the ASUS, within several minutes the unit gets very hot, like I’m continuously writing to it at full speed. When I connect it to another PC which detects it correctly it is only lukewarm even after hours.
I don’t think the problem is caused by power shortage as the notebook easily spins up bus powered external mechanical hard drives, even 7200 rpm ones with 6-700 mA startup draw.



Thank you for sending the log files via email, unfortunately they don’t show a specific cause for this behavior. The logs do show the USBC-NVME enclosure is detected but the installed SSD is not being detected, as if the drive were not installed into the enclosure when the PlugDebug tool was run.

ASUS’s US support site was offline earlier, but I did not find any updated BIOS or firmware for the laptop on the international support sites. BIOS or system firmware could affect USB connectivity.

The excessive heating without the file system detected by the computer is not expected behavior, but is likely caused by the failure for the SSD to be detected. I don’t expect it is writing any data, simply it is stuck in a high performance state, essentially idling at full power instead of entering a lower performance state.

I recommend we attempt to re-flash the firmware using the USBC-NVME firmware update available from our download page here ( ).

The README.pdf file includes the full update instructions, please right-click on the “” archive and extract the contents before running the update application ( double-clicking to open the zip file and running the update utility will cause an error ).

After updating the firmware on the enclosure please try it with the ASUS notebook again and let me know if this helps.

If you have access to a powered USB 3.0 hub we can try connecting the hug to the ASUS, with the enclosure connected to the hub to help rule out a power problem.

Thank you, I look forward to your reply.

Plugable Technology


I did what you told me and here is what happened:
I connected the unit to my desktop PC and it was detected correctly as usual.
Extracted the firmware update folder, started the tool, clicked Update. Without starting the process it said FAIL.
Then, the device disappeared as a connected USB, I disconnected then reconnected it and the same happened as on the notebook: “E:\ is not accessible. Invalid function.” This is on the PC, which always detected the unit before.
After trying connecting it several times I quit then re-run the update tool, clicked Update again. The process finished and it said PASS. The device works again on the PC but still not on the notebook.
I created a plugdebug log on both machines and sent to you if it tells anything.

I don’t have access to a powered USB hub but I’m pretty sure this is not a power problem. Rather, something looks really wrong with the Realtek firmware or the chip itself.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.