Xorg.conf configuration for display link adapter on Linux


#1

I took the plunge and picked one of these up for my Linux box. I simply need a second working X server on my second display.

No matter which tutorials I follow though I cannot seem to get it to work. I’m running on the 3.0 version of the Linux kernel and I’ve install the display link xorg driver and built and installed the latest libdlo. I know the adapter is functioning with my system because running “sudo make check” from the libdlo directory causes my external screen to display the test images A-OK.

This is my current xorg.conf - http://pastebin.com/Vr6Jd2D5

I based it off of settings I found here - http://mulchman.org/blog/?p=21

My primary screen comes on line after a reboot, but I still get something on the external display. I can confirm that there is a displaylink_drv.so located in my /usr/lib/xorg/modules/drivers directory.

Anyone know what I am missing here?
~Jeff


#2

Hi Jeff,

First off - just to set expectations, the situation for multi-adapter multi-monitor on Linux is a bit of a mess. So the good experience people are used to on Windows isn’t possible today (as you already know)

That said, Two things that might be off on the xorg.conf linked to above:

  1. The DisplayLink driver is 16bpp only, so it might cause problems to set Depth 24 in xorg.conf. I’d recommend just removing the Depth (and perhaps the whole SubSection “Display”). Or, another alternative is to set both to 16bpp.

  2. I’ve seen several reports that the DisplayLink device has to be set up as Screen 0 in the layout - I’d recommend swapping the Default Screen and DisplayLink Sreen in the layout.

Can you try those two things out, and see if it helps?

Can you confirm that you get a “green screen” on the USB display when you first boot, and it only switches to blank/black later, once you start X or another client?

Sorry the state of things on Linux isn’t easier!

Thanks!
Bernie


#3

Bernie,

Wanted to say thanks for the prompt reply (on a weekend no less!). What described was half of what I needed to get the device rolling. The other half I figured out from checking my xorg log files. It seems that setting

Option “fbdev” “/dev/fb0”

Was part of the issue, after I set it to

Option “fbdev” “/dev/fb1”

It jumped right online. Thanks once more - I plan to give you guys a plug on my tech blog later next week, if there is anything in particular you’d like me to mention let me know.

~Jeff Hoogland


#4

Op! Looks like a I spoke a little bit too soon, almost there though I can feel it…

So here is my xorg.conf now - http://pastebin.com/Gq0z8Wxg

The issue is that I am only getting an X display on which ever screen I have set to 0. So if I set my internal to 0 the external doesn’t work and vice versa.

Oddly enough though, when I set the external display to the primary display my TTY screens still show up on my laptop screen.

Any ideas?

~Jeff


#5

Hi Jeff,

I’m not sure on next steps – I’ve been hoping that the questions you posted elsewhere would yield some answers. :slight_smile: But since I haven’t seen any, two changes might be worth trying (a bit shot in the dark):

FIrst, change DisplayLink to be screen 0 (just because others have reported that’s essential).

  1. Add an option to explicitly disable Xinerama:

Section “ServerLayout”
Identifier “Server Layout”
Screen 0 “DisplayLinkScreen”
Screen 1 “Default Screen” 0 0 LeftOf “DisplayLInkScreen”
Option “Xinerama” “off”
EndSection

And 2) set both displays to Depth 16 (right now you have the DisplayLink screen as Depth 16, but the Intel as Depth 24.

Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
SubSection “Display”
Depth 16
Modes “1366x768”
EndSubSection
EndSection

The ways of X are mysterious. Let us know if either helps resolve the either-or conundrum here …

Best wishes,
Bernie


#6