Worked for about 3 weeks on my new Surface Pro 4....now I get USB device not recognized.....


#1

New Surface Pro 4 with Windows 10 installed.
Bought the Plugable USB 3.0 Docking Station.
First time installed everything worked fine for about 3 weeks. I’ve changed nothing on my computer nor have I added any new devices to my computer or Docking Station.
I now get a Windows error message “USB Device Not Recognized”
I’ve tried the obvious things…reinstalled the driver, I’ve unplugged and rebooted a number of times, etc. but I can’t get the Surface 4 to recognize it anymore.

Any solutions !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1390969/Screenshot_inline.jpg?1459391906)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1390969/Screenshot.jpg?1459391906)


#2

Hi David,

Thanks for posting. I’m sorry your docking station stopped working properly, and I would be happy to help.

On the surface (no pun intended) the dock may have developed a fault, in which case we will of course send a pretested replacement. A quick test to help rule out one factor that would cause said replacement to behave in the same manner, we’ll want to completely reset the docking station to see if that changes the behavior.

Please disconnect both the power and the USB cables from the back of the dock and keep them disconnected for at least 30 seconds. Reconnect the power cable and wait at least 10 seconds and then reconnect the USB cable to see if the dock is now detected correctly.

If that helps, great! If not, please send an email to support@plugable.com with ‘Ticket 138201’ in the subject line along with your Amazon Order ID number, serial number from the bottom of the dock and your preferred shipping address and we’ll get the replacement process started.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3