Windows 11 compatibility issues?

I have a standard vertical UD-3900 purchased in 2019 and have been very happy with it. It hooks to my laptop and two Acer monitors. I use the two Acer monitors and bluetooth keyboard and mouse to do work at my desk, with the laptop set off to the side. I recently upgraded to a new more powerful Dell Laptop w/ Windows 11 and 32 Gb RAM. Since setting the new laptop up, I have had a slew of different “glitchy” problems. Dell support spent a long time going thru my laptop and performance capabilities and determined that they “believe” the issues could be related to the UD-3900. I updated to the latest driver for the UD-3900 just a couple weeks ago, but the “glitchyness” doesn’t seem to have resolved. An example of the glitches: This morning in windows file explorer, I tried to create new sub folder, but the new folder would not show. I had to back up one level in file explorer, and then back into the folder where I created the new sub folder, and only then would new folder show. Thus, I tried to reboot the laptop, but laptop completely froze in a black screen showing “Restarting…” and would not change. Even pushing and holding the laptop’s power button did nothing to release the freeze. It stayed like this for a long time until I unplugged the UD-3900 from the laptop, and only then did the laptop unfreeze and restart as per normal. Another common glitch is that when I open a new window or file from a program/app while working from one of the large monitors, it opens on the laptop’s screen instead of the monitor I’m working in. I then have to go drag the new window over to the display monitor where I’m working. This is very common but intermittent. These are just a couple of examples of what is a very variable set of “glitches” I keep experiencing with this new machine and perhaps the UD-3900.

Hi Jeff,

Thank you for posting!

To recap the issues you describe, my understanding given the information you provided is:

A. When attempting to create a new folder within Windows Explorer, the new folder did not appear. In order to see the ‘new’ folder, you had to move up one directory level and then back down to where you created the folder in order to see it (in effect ‘refreshing’ the Explorer view)

B. When attempting to reboot the laptop with the UD-3900 dock connected, the the laptop would not reboot. You had to disconnect the dock in order for the system to restart.

C. Application windows do not always open within the display you expect.

Can you please confirm if my understanding is indeed correct? If I am mistaken please feel free to correct me. Apologies in advance if the question appears in any way redundant, however I just want to ensure that I have the details correct and do not make any incorrect assumptions.

Presuming for the moment that my understanding is indeed correct…

In regard to item ‘C’:

The behavior you describe is controlled completely by Windows. The UD-3900 dock or its associated DisplayLink driver have no control over which display an application window appears within. The behavior you describe is fairly common, as Windows is known to behave inconsistently in this regard.

One potential workaround for this behavior is to move an application window to the desired display and then close the application by right-clicking on the application’s title bar and then clicking ‘Close’ from the context menu that appears. This can often help Windows ‘remember’ which display an application should appear within the next time it is opened, however please be aware that this may not always work as intended.

In regard to item ‘B’:

There are rare cases where a laptop may not boot as expected when connected to the dock, and in those cases the cause is typically an external device connected to the dock and not the dock itself. We have a knowledge base article that speaks to this topic and the methods to isolate the behavior further here → https://kb.plugable.com/question/811819

However, your description suggests that the laptop was unable to shutdown properly and it did not reach the point where the system was attempting to boot. As a result, I am afraid I cannot be sure of the cause of the behavior you describe given the information available.

In regard to item ‘A’:

I am afraid I cannot be sure of the cause of the behavior you describe given the information available.

Given your description, I would suspect that the cause lies somewhere ‘outside’ of the UD-3900 or its associated DisplayLink driver. This is because the UD-3900 relies on the host computer’s internal CPU and graphics processing unit (GPU) in order to generate the image shown on the dock-connected displays. In other words, the UD-3900 does not create the image shown, it only displays the information that Windows provides.

With all that said, our next step is to get some additional information in order to investigate the behavior you describe in ‘A’ and ‘B’ further:

Can you please send an email to our direct support email address → support@plugable.com with ‘For ticket #- 387196’ in the subject line that contains the following information?:

  1. The Amazon Order ID number for your UD-3900 purchase
  2. While the UD-3900 is connected to your new Dell laptop, the output of our diagnostic utility PlugDebug → https://plugable.com/pages/plugdebug

This information will help us to determine the next steps.

** Please do not post the above information here in our public forum (it contains personally identifiable information) **

Apologies for the frustration (and for the long post), and thank you for giving us the chance to help!

Bob
Plugable Technologies

Thank you for the response. Unfortunately, the problems listed above are now the least of my worries following the most recent Windows 11 Update that just happened a few days ago. Now I have intermittent sound/audio, but mostly NO audio in applications, when connected to the UD-3900. There is no sound coming out of the laptop’s internal speakers, but there is sound coming out of the headphones when plugged into the jack. This includes no speaker audio on MS Teams and google meet. No audio in web news videos using Chrome, no audio in Youtube. I have spent a few hours with Dell technicians, I have uninstalled all DisplayLink software and used the DisplayLink Cleaner, with UD-3900 disconnected and powered off, and then fresh install of the latest DisplayLink driver at plugable.com. And the problem at first seems to be resolved, but then, it comes back again after a few hours or less (at first the sound is working, and then later it is not). Once a new DisplayLink driver install is complete, and I plug in and power on the UD-3900, the sound settings on the laptop instantly change to “Plugable Audio” instead of the PC’s default which is “Intel Smart Sound Technology for MIPI SoundWire Audio.” With the “Plugable Audio” option chosen, I get no speaker sounds at all, except perhaps the Widows system sounds (chime) at startup. Changing to the “Intel Smart Sound” option will sometimes resolve the no sound issue and sound will start playing from the laptop’s speakers. However, this is an intermittent problem. Sometimes the internal speaker sound will work well for a day, with the Laptop going to sleep multiple times in that day, but then other times, it seems waking the PC from sleep and sound is then not working again. Sometimes rebooting the Laptop helps and sound comes back, but sometimes it does not. Maybe this issue will be under a new ticket #?