Windows 10 USB 3.0 no connection


#1

Hi, I recently upgraded to windows 10 and everything seemed to be working smooth however, I seem to be having trouble keeping a network connection. I have Windows Anniversary installed and I’m using the latest display driver listed in these instructions: http://plugable.com/2015/07/27/window…

Once I uninstalled and cleaned the driver and rebooted as per the directions, I tried to install the display drivers (DisplayLink+USB+Graphics+Software+for+Windows+8.0+M1) but the dirver install fails after the cleaning up files step.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1468658/Fail_inline.JPG?1471446243)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1468658/Fail.JPG?1471446243)

So now the whole driver won’t install. I’m not sure if it has partially installed as I have the same network issues I have before. The connection shows that something is connected but I can’t get to the internet.

Please advise.


#2

I have also tried with the adapter connected, without it connected, running the program with Win7 compatibility nothing seems to work, It dies right after the cleaning up files step.

After the fail, it thinks its connected and will not run again. You have to run the cleaner to remove the drivers, reboot and start again. When I do plug in the adapter the 2nd monitor doesn’t detect but it detects an Ethernet connection but can’t connect to the internet.


#3

Hi Mallory,

Thanks for posting! I have just replied to your direct support request via support@plugable.com. Please just respond to my direct email so we can keep everything in one place (I’ll update this post as necessary), but for the benefit of anyone else following this thread…

The blog post you mention is over a year old at this point, and the latest information for problems with Windows 10 and the latest Anniversary Update are here -> http://plugable.com/2016/08/01/window…As a matter of course, the latest DisplayLink driver we recommend for our products will always be located here -> http://plugable.com/drivers/displaylink/

To the behavior you have encountered with the installation timing out, that may indicate it might be a permissions issue. Even if your user account is in the Administrators group on your system, a good way to mark sure permissions are not part of the problem is to ensure that both the Cleaning utility and the installer mentioned in my latest post are run as Administrator by manually elevating permissions.

To do so just repeat the steps in the post but when running both the cleaner and installer instead of double-clicking on them to run them, right-click on them and select ‘Run as Administrator’ from the context menu.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#4