Windows 10 Ethernet problem with USB 3.0 docking station


#1

Since upgrading to Windows 10 I have no Ethernet connection via my USB 3.0 docking station. If I plug the Ethernet cable directly in to my computer it works fine, but that rather defeats the object of having a docking station! Any suggestion on how to fix this? I have already installed the latest Displaylink drivers (to solve a problem with my HDMI second screen).


#2

Hi Eric,

Thanks for posting. In most cases, a “clean” installation of the DisplayLink drivers after upgrading to Windows 10 helps get the drivers in a good state.

Can you please try the steps outlined in the link below:
http://plugable.com/2015/07/27/window…

Please let us know if that helps get the ethernet working as it should, and we can go from there.

Thanks!
Gary


#3

Hi Gary,

I have already updated with the latest DisplayLink 7.9 driver. I just tried doing it again to be sure, and got the message confirming that DispayLink was up to date.

Any other ideas?

Cheers
Erik


#4

Hi Erik,

Just to confirm, did you run the “cleaner” tool in steps that were linked to previously? (That’s key, since it can remove any partially-installed DisplayLink drivers such as a non-functioning ethernet driver.)

If you did indeed run the cleaner before reinstalling, we’ll want to take a look at some system logs. Please run our log-gathering tool from the page below:
http://plugable.com/support/plugdebug

You’ll want to run the tool with the dock attached. It will save a .ZIP file to your Desktop which can then be emailed over for us to have a look. Please mail the file to support@plugable.com (subject: Ticket 116628) and we’ll dig in deeper.

Cheers,
Gary


#5

We worked with Erik via email to find a solution, and I’m pasting the resolution steps below for the benefit of others who may encounter this behavior.

In a nutshell, the problem was that if Kaspersky AV software is installed on a system, and then that system is upgraded to Windows 10, the Kaspersky software can block new network devices from being installed.


Thank you for giving that a try and for the updates. This seems like clear evidence that something is simply blocking the driver installation.

Doing some additional research, I’m seeing some reports of people encountering driver installation issues if they had certain antivirus installed during the Windows 10 upgrade.

We’re going to want to uninstall the Kaspersky security software on your system temporarily to see if that allows us to proceed. (This is one of several forum posts on Kaspersky’s site that recommend this approach: http://forum.kaspersky.com/index.php?.. )

So please try the following:
-Disconnect the docking station

-Uninstall the Kaspersky antivirus software

-Reboot; after reboot make sure to check that Kaspersky is no longer in your Programs list. If so, uninstall any remaining elements (if it won’t uninstall properly, they have a removal tool we’ll want to try.)

-Run the DisplayLink cleaner program:
http://www.displaylink.com/downloads/…

-Reboot

-Reinstall the DisplayLink drivers; reconnect the docking station when prompted

-Reboot when prompted

-If things are working after the above, reinstalling Kaspersky at this point should be okay


#6