window does not refresh


#1

I have the plugable docking station hooked up to my laptop and a Dell monitor.
i am running windows 7
There are certain windows (windows live mail, media center) that do not refresh or just show blank on the dell monitor, but when dragged to the laptop they work properly. when moved back to the dell monitor, they again do not work. it feels like a driver or setting issue, but i cant get it. I have updated the displaylink 5.5, and all other drivers are up to date.
thanks


#2

Thanks for posting. The first thing to try when this kind of problem happens in Windows 7 (rendering problem within a specific window, especially video playback windows) is to check if Windows Aero is enabled. Microsoft has a useful troubleshooter for this:

http://windows.microsoft.com/en-US/wi…

Can you let us know if the troubleshooter finds anything, and how it goes after running the troubleshooter?

Thanks!
Bernie


#3

Thanks for getting back with me.
You are right, especially video playback, but other windows are not rendering. Internet explorer does fine, but windows live mail does not.
I ran the troubleshooter, and it said it did not find any problems. I tried it again and still it does not work.

if it helps at all, the lap top monitor does run/play these items. the problem only exists on the Dell monitor that is hooked up through the docking station.

Let me know of any other solutions i might try.
thanks


#4

This kind of within-the-window application specific issue only on the USB-attached display, would be a software issue. These are usually solvable.

Would you be willing to run the DisplayLink Support Tool (http://plugable.com/support/displayli…) and email us the .zip output, to look in more depth at what might be happening on your system?

Thanks for your patience!
Bernie


#5

I sent one. Let me know what you find out.


#6

Thank you! We got it.

The logs say that Windows 7 is in “Basic” mode, not “Aero” mode - and that would explain the symptoms.

What’s confusing is why the Windows troubleshooter here (http://windows.microsoft.com/en-US/wi…) didn’t find that and fix it - I’ve found it fairly reliable before.

Microsoft does have a fancier Aero troubleshooter that downloads a program to run. You might want to try that: http://support.microsoft.com/mats/aer…

But getting switched from Basic to Aero mode is the key to getting those windows that arn’t refreshing, working.

The troubleshooters usually solve it. Let us know if they don’t in this case.

Thanks!
Bernie


#7

hmm. i did run the first one. i will try this one too though. would that work for 1 monitor and not the other? because only 1 monitor is not rendering these windows.
thanks. i will try this next.


#8

ok. i tried this. it came back with:
troubleshooting is comple
however, we did not detect any issues common to this problem and therefore, no fixes were applied

any other ideas?


#9

Hi L - Sorry we’re slow on the replies. The tools are giving us two conflicting datapoints: The DisplayLink debug tool reports your machine is in basic mode, and the symptoms you’re reporting are what you’d see on a machine in basic mode.

But the Windows’ Aero troubleshooters report no problem.

We’ll try to dig deeper to figure this out. If you have extra time, it might help if you re-ran the displaylink support tool with the adapter connected and emailed us an updated file, just to double-check that we really are getting conflicting results.

Here’s what we saw in your last datafile for system info (Note the “Desktop Mode: Basic”):

Computer: Hewlett-Packard - HP Pavilion dv6 Notebook PC
OS: Microsoft Windows 7 Home Premium (x64-based PC), No Service Pack, English
OS Build: 7600 (Debug = False)
System Bios Date: 09/14/10
System Bios Version: F.13
CPU: Intel® Core™ i7 CPU Q 720 @ 1.60GHz
Memory: 6078 MB
Free Space: 256730 MB
Primary Resolution: 1280x1024x32
Graphics: ATI Mobility Radeon HD 5650 (ATI Technologies Inc.)
Graphics Driver: 8.692.1.0 Dated 2010-01-22
WEI Base Score is 5.9, CPU 7, RAM 7.3, GPU 6.7, Gaming 6.7, Disk 5.9
Desktop Mode: Basic
Installed Package: DisplayLink Graphics (5.5.29194.0) on 2011-01-23 Status is Installed
Installed Package: DisplayLink Core Software (5.5.29055.0) on 2011-01-23 Status is Installed

DisplayLink Version: 5.5.29055.0
Optimize for Video: No Value (Off)

--------- Nivo Info ---------

Nivo’s currently attached: PID_0377\005993

Nivo’s that have been attached: USB_0377-005993

--------- Nivo Config ---------

DEL4015-DC323615BEV1
Mode = 0x0x0@0
Rotation = 0
Attached = yes

Thanks for your patience!
Bernie


#10

i am new to this windows 7 stuff.

now that i knew what i was looking for, i tried a couple of thigs last night running the display link and then checking the data file on my own i tried a few things checking the data file in between tries.

i think i found something that worked. it makes no sense to me, but maybe it will to you. i changed my theme to an aero theme and the new data file indicated that the desktop mode was aero. then i tried some of the applications that i had been having trouble with and they worked fine. it seems that the problem may be solved.

thanks for your help.


#11

Hi L - Glad you’re up and running!

Maybe in addition to the troubleshooter, your theme had been explicitly changed to one that triggered basic mode - so with that fixed, the troubleshooter would/should work from here out.

If you have any trouble in the future with this, here’s a discussion that may be related (about Win7 switching into Basic mode against the desire of the user, especially on recent high end systems):

http://social.answers.microsoft.com/F…

Maybe some of the wierdness you’ve seen is related.

Thanks for your patience, and glad apps using DirectX are back up and running on your USB attached screens!
Bernie


#12

FYI I had this problem on a mac, so read this if you are too.

I had windows that displayed properly and then one day they stopped working and simply displayed the last image that the browser had displayed.
Seeing as I need two monitors for work, this was unacceptable, so I set to figure out what the problem was right away.
It took me a while to figure it out…
I had been using the “Spaces” feature up until about a week ago, when it became annoying with so much desktop space. I disabled it, and with it came my problem. I just reenabled it and the windows work again.


#13