Why did my Super Speed 7-Port USB 3.0 Hub stop working? How do I get it to work again?


#1

I tried to email you, but it bounced. I am frustrated with your company and getting angry.


#2

Hi Rachel - Sorry for the frustration. Can you double-check the email address it was sent to? It’s support@plugable.com (note the one ‘g’ in plugable). If you can, include your Amazon order # in that mail.

In terms of figuring out why the hub stopped working – the number one and two most common issues are connectivity with the PC or Mac, and power to the hub. First steps is we’ll have you unplug / replug those USB and power connections to double-check that all’s well (plugging into a different USB port if possible).

It it turns out to be a hardware failure, we’ll set it right. Thanks for your patience while we work to help!


#3

Once again, my Plugable has problems. Only one of the USB ports is working. I tried your suggestions from last time, but it’s still not fixed. Can you help me? Thanks.


#4

Please help!


#5

Help. It stopped working again!


#6

Is anybody going to answer me? I just got an iphone 6+ and my Plugable with 7 USB ports only has one that is working. I have my phone plugged into a port, but the charging percentage is dropping not getting better. Please help!


#7

Hi Rachel - Sorry for the frustration!  This USB hub is not a smart charger – the iPhone 6+ (and other Apple devices) use a proprietary charging method that requires special support outside of the USB standard.  Many/most hubs doesn’t do that – they only supports the USB 3.0 standard.  We have other products that are smart USB chargers.

System specifics are probably best handled privately via email. So if you could, email support@plugable.com and we can get all the details of what you’re trying to use the hub for (which devices for regular USB use vs. which devices to charge) and recommend possible options for you. 

Thanks for your patience!


#8