Why are USB 2.0 devices only recognized if a USB 2.0 device is inserted during power-on of USB3-HUB7BC?

I’ve got the 7-port USB 3.0 hub, USB3-HUB7BC, USB vendor:product ID 2109:2811. It’s connected to a motherboard USB 3.0 port on an Intel Sunrise Point-H USB 3.0 xHCI Controller (rev 31). I’m running Linux 4.15.11-1 on a 64-bit x86.

If I power on the hub with no devices inserted, or with a USB 3.0 device inserted, then when I later insert any USB 2.0 device, the device is not recognized. In Linux, dmesg shows no messages at all. However, if I have any USB 2.0 device inserted before I power on the hub, any additional USB 2.0 devices are recognized just fine. I’ve tried a Plugable USB audio adapter and a generic USB 2.0 flash drive, and either works as the first device or the second. USB 3.0 device also work, and dmesg will show them as new SuperSpeed USB devices.

Why might this be? Is there a Linux driver issue, a firmware issue with my hub, or something else?


Hi John,

Thanks for reaching out to us, I am sorry this is not working as expected.

Based on your description of the problem, this may be related to a firmware version issue in the USB hub. We have a Windows compatible firmware update utility for the chipsets inside this hub ( https://s3.amazonaws.com/plugable/bin… ). If you do not have a Windows based system available we can send you a pre-updated and pretested USB hub to replace the current device.

Instructions for updating the firmware:

  1. For Windows XP, Vista, and 7, we recommend updating the USB 3.0 host controller drivers before running the firmware update utility. These drivers are normally provided by the system manufacturer

Note: this firmware update will most likely not work through USB pass through to a Windows Virtual Machine, it will need to be run on a native Windows system
2) Connect the hub to the system, remove any devices connected to the hub
3) Start the firmware update application ( above )
4) If the hub is not detected, disconnect and reconnect the hub and select the Scan Device button
5) Follow the prompts to complete the firmware update

Please let me know if this helps to resolve the issue, or if you do not have a Windows System to perform this update on,

Thank you,

Plugable Technologies

Thanks so much for the response. I borrowed a Windows 10 laptop and ran the updater. It was a bit confusing, in that the first time, it seemed to find one target hub, but after power cycling the hub and re-scanning with the updater, the updater found two target hubs. I ran the updater a couple more times.

Anyway, after running the updater, I attached the hub to my Linux workstation and confirmed that USB 2.0 devices now work with the hub whether there was a USB 2.0 device inserted at power-on time or not.

Hi John,

Thanks for great news! I am glad the updated firmware resolved this issue.

I will be closing this thread as resolved.

Please feel free to email us at support@plugable.com or start another thread if you have any additional questions.

Plugable Technologies