Why am I getting a "USB Over current" warning on OS X (10.5) with the USB SATA dock?


#1

Just got a brand new USB SATA dock, and when plugging it in to OS X consistently get 'USB Over Current Notice’s popping up (see attached picture)!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0glDJvEzlTlRKeS5xjchEs-p5n5vBfZLoSTYo52JObQp.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/191160/box.png). Naturally the drive won’t mount. It’s not a defective cable (I’ve tried several cables that I have here), and it’s not specific to one machine (I’ve tried using two laptops and a desktop so far, and have tried all USB ports on all of the machines).

The problem occurs regardless of whether the unit is powered on or powered off when I plug it in (the messages appear instantly even if the device is off), and regardless of whether or not I have a drive docked in the unit. Do I have a defective unit, or is there another issue at play here?


#2

Hi Geva,

Thanks for writing with this problem.

Do you have the storage dock’s power supply plugged in, before the USB cable is connected? With the power connected, and the dock on/off switch on, you should see the red LED on the front light up to show the dock is operating on its own power. Then you can attach the USB cable.

Plugging in USB first will generate the overcurrent condition, because the device will try to pull enough power to drive a hard disk – and there simply isn’t enough in most cases, without the dock’s own power supply plugging in.

If you don’t see the red LED light up before USB is connected, something is going wrong with power, and we can resolve that.

Let us know,
Bernie


#3

Bernie,

Thanks for the speedy reply. I tried powering the unit up before plugging it in, and it didn’t seem to help. I think there may have been a short on the SATA connector - I noticed some deposits on it and cleaned them off with compressed air, and things have been fine since then.

Thanks for your help,
Geva


#4

Hi Geva,

Glad it’s working. Thanks!

Bernie


#5

I am having the same issue…even if I don’t had a Sata drive plugged in. I tried on two different computers…macbook pro and imac and it does the same on both. Power adapter is plugged in, but even without a drive, I get the USB overload error.


#6

Hi Ramona,

Thanks for reporting this.

We haven’t been able to see this problem (on Mac or any other), but with two reports, we’re definitely going to be on the look out.

In addition to trying the method Geva used to resolve the problem, two things to try or make sure of:

  1. Make sure the dock’s power supply is plugged in, and power switch on back of dock is on before plugging into USB (it sounds like you’re already doing this)

  2. If you have a USB hub (or any external USB devices with extra USB ports) around – try both plugging the dock both directly into your PC, and then also try plugging into an external USB hub port. Normally, plugging directly into PC is one way to eliminate errors (because the power supply is beefier), but in this case, plugging into a hub might actually help resolve the resolve the error.

If neither of these things works, and given that Geva’s problem was a short – unfortunately there’s a possibility of a hardware problem. Just email support@plugable.com with your Amazon order # and we’ll get you taken care of.

Thank you!
Bernie


#7

Thanks Bernie for your prompt reply. I did try to plug the dock into the USB port on the keyboard, but that also gave the same error. The only thing I have not tried yet is to get a different USB cable and see if that makes a difference. I don’t think there is a short in my dock because it did the same thing with no drive or other card in it. I just plugged the empty doc in and immediately got the message.

I did try plugging the power supply in first, then plugging the USB cable into the dock, then to the main computer. I even unplugged the keyboard and mouse to see if that made a difference. They are the only other USB devices that I have plugged into that computer. The laptop didn’t have any USB devices and it did the same thing.

I will try another USB cable and if that does not work, I will email the order number to support.

I appreciate the help!
Thanks,
Ramona


#8

Ramona had a bad unit that needed replaced. We sent Ramona a new one, and she’s up and running. Thanks Ramona, for your patience!


#9