Visual Studio 2010 and WPF issues


#1

Hello - I’m having an issue with Pluggable UGA-2K-A and Visual Studio 2010 (please see attached). I’m running with DisplayLink driver v 5.6 M1. My GPU is Intel Integrated (machine is HP laptop EliteBook 6930p).

I know the driver has had issues with WPF and VS 2010, but judging by the other posts on the topic, these issues should have been resolved in driver versions 5.5 and higher. However, this issue still seems to be in effect with the current latest version of the driver.

Unfortunately since the DisplayLink monitor is my main monitor, this is a quite a serious issue for me (I’m just switching to working with VS2010 and moving back to VS2008 is not an option).

Your help in resolving this issue is greatly appreciated.

Regards,
V.K.

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0sXGhEo1wg6O1YvOF8EWDSqtCNUBx1eAQa2MEdBCNDdwnMh-cD2kHqSnam-QCpCvVQ==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/487598/VS2010.png)


#2

Hi VK,

Thanks for posting! Yes, you’re right - VS 2010 can have special issues because it uses WPF, which in turn uses DirectX, which makes the rendering path it goes through resemble a game more than a traditional Win32 app.

The DisplayLink drivers have been making ongoing fixes/improvements to improve WPF compatibility.

If you are on Windows 7 or Vista, I would check first that Aero is enabled by running the Windows Aero troubleshooter http://windows.microsoft.com/en-US/wi… – that will resolve WPF issues in most cases.

If it doesn’t work for some reason, the next thing I would try it to set your display to 16bpp (rather than 32bpp), which may kick it into a simpler rendering path.

If you are on Windows XP, also try 16bpp, but let us know if that doesn’t work and we’ll figure out next steps.

Thanks for trying those things and letting us know the outcome - and thanks for your patience!
Bernie


#3

Wow - Bernie - you guys are the best!

Going through the Aero troubleshooter did its magic and now my VS2010 works!!!

Thank you very much for helping me out so quickly - never have I seen such a quick response to a support call (and on a weekend too). I should have contacted you earlier…

P.S.
For your reference, I am using Windows 7 Enterprise, Version 6.1 (Build 7600).

Best regards,
Vassil


#4

Hi Vassil,

Thanks for letting us know. We’re glad to have you up and running!

Best wishes,
Bernie


#5

Hello Bernie,

After turning on Aero I rediscovered the reason why I had turned it off in the first place - it was eating too many CPU cycles which hurt Pluggable’s performance - the picture became choppy.

There is a middle ground though - I found out that all one needs to do to get VS2010 to work is turn on the “enable desktop composition” visual effect - please see attached.

I guess this may be helpful to others having similar issues with Win7 and VS2010.

Cheers,
Vassil

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0ophNI2Si0jksNwV20hERmybejtQY7rvWoP94KlELXKSRILcN70raAVN9QMOgnvwtw==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/488124/Aero_Performance.png)


#6

Thanks for this tip, Vassil! I hadn’t tried that setting on VSTS2010 yet.


#7