Video playback not functioning properly over Plugable UGA-2K-A


#1

I have been using two UGA-2K-A USB to VGA/DVI adapters with my Lenovo T61 quite successfully for a couple of months. The UGA adapters were plugged into a USB 2.0 powered hub, and I did not use the T61’s display, only extending to my two monitors (an HP & Acer).

Recently I updated my computer to an HP 8460p, which includes a docking station. I now have the USB 2.0 hub connected to the docking station and have otherwise replicated my previous setup with the 2 monitors. However, I have started suspecting that there may be a problem with the video drivers. Here are the behaviors I’m seeing:

  • I cannot play any native video files (I attempt to play a WMV file but I only hear audio, with occasional single-frame updates). I don’t see a problem playing youtube videos through a browser, however.
  • When I use Skype, the part of their UI that displays the current call information never refreshes, such that I cannot mute, bring up the dialpad, etc.
  • When I use IE9, some web pages do not refresh at all.
  • When I disconnect the UGA adapters, I do not see any of these problems on the laptop display itself.

I’ve made sure I’m using the latest DisplayLink version, and otherwise my graphics driver appears up to date, so I’m at a loss as to why this is happening.

Would I need to install the monitor-specific drivers onto the laptop bypassing the UGA adapters FIRST, before I reconnect the UGA adapters? Is there another missing software component or upgrade that I am missing?

Any help would be appreciated.


#2

Hi zuidervled,

Thanks for posting your question here! We’ll be happy to help. There’s a couple of avenues to pursue concerning the video performance with your new rig.

First, try running the UGA-2K-A from the new computer without the docking station connected. Often, proprietary OEM docking stations have an external video card in them and can be incompatible with USB Graphics.

Next, try running the aero troubleshooter, here’s how:

http://windows.microsoft.com/en-US/wi…

It this finds and fixes any issues, you’ll probably see some improvement. Let me know what your results are and we’ll figure out next steps.

Thanks for your time,
Jerome.

Plugable Technologies


#3

Running the Aero troubleshooter solved my problem! It turned out the Desktop Window Manager wasn’t enabled, for unknown reasons. After the troubleshooter automatically enabled it, I was good to go.

I had also tried bypassing the docking station, connecting the hub directly to one of the USB ports on the side of the laptop, but the same problem was occurring.

Thanks for your help!
Nick


#4

Hi zuidervled,

GREAT!!! I’m glad to hear you got it working! Thanks for letting us know the outcome.

Enjoy,
Jerome.

Plugable Technologies


#5