USBC-E1000 Not working on HP ZBook G3 with Windows 7


#1

Tried installing the USBC-E1000 network adapter on a HP ZBook G3 with Win7, and not having much luck. I installed the latest drivers, and connected the device, a message pops up saying “Device Driver software not successfully installed” . In the device drivers under other devices it has "Universal Serial Bus “USB” Controller.

I have tried both USB-C ports, and get the same thing. No lights come on if I connect the USBC-E1000 to an active network cable. Any Ideas?

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1608057/2017-06-0911_51_10-DeviceManager_inline.png?1497024155)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1608057/2017-06-0911_51_10-DeviceManager.png?1497024155)


#2

Hello Keith,

Thanks for contacting Plugable support. I’d be happy to assist you.

This actually means that the USB 3.0/3.1 controller drivers are not installed. You’ll want to download this from HP. Once that driver is installed, our Ethernet adapter should be detected properly. I suspect if you connect a different USB-C device, you’d get the same error.

If you need assistance doing this please let me know.

Thanks!
Josh


#3

I downloaded the latest USB C drivers from the HP website, and this has fixed the problem! Thanks very much!


#4

Great news Keith!


#5