USBC-7in1 SD card slot not detected on M1 Mac

I’ve just tried to use the SD card slot with an UltraII SanDisk SD card and my M1 Macbook Air doesn’t find it at all. The card works ok in the camera it is from. It doesn’t seem to go in very solidly but I can’t seem to push it in very much further that it goes too… so not sure what is wrong.

The unit is normally plugged in via the LG ultra fine 4K monitor but it also fails to recognise the card when plugged directly into the Mac and only the SD card is pushed into place.

Hi Adam,

Thank you for contacting Plugable support. We are sorry to hear you are experiencing this issue and would be happy to help assist.

To help clarify, only the SD card is not being read from your USBC-7IN1 card hub? Is this correct? If you were to plug in another device such as a USB drive in your USBC-7IN1 can you see your USB drive in your macOS?

Best regards,

Michael S.
Plugable Technologies

Hi that’s right - all the other connectors work it.

Hello Adam,

Thank you for providing this additional information. Based on your description I would like to confirm that you are attempting to insert your SD card in the correct orientation. You stated, “It doesn’t seem to go in very solidly”. Please make sure that you are inserting the card as shown in the images below.

I would also be interested to see if another SD card produces the same results. If possible, could you try a different SD card to see if the behavior changes?

If you can confirm you are inserting the SD card correctly and (if possible) another SD card does not improve the behavior then we can certainly send you a new, pretested USBC-7IN1 under your warranty to help resolve this issue. In order to do so, we would need to acquire some additional information. When you have a moment, please contact us directly by emailing us at and referencing Ticket # 347794 so we can match things up and discuss the next best steps.

We look forward to your reply.

Best regards,

Michael S.

Thanks for this (I’ve been on hols so not been able to action). I’ll give this a go this week, but from what I recall, I tried both orientations, and I think it doesn’t go in at all well the ‘wrong’ way due to the shape? But I will try another card to see and then let you know!

I’ve just noted that the one I have is different to the one shown in the image you posted. Mine is the USB-C one, which shows the card going into the device with the metal strips (visible on your image) on the opposite side to the ‘plugable’ branding (ie the side with the QR code visible). I can’t actually insert it at all properly with the metal strips on the same side as the logo. And when I do insert it ‘correctly’ it rocks (ie it can be wobbled laterally, not ‘it’s amazing’… :slight_smile: ). Will try with another card tomorrow.

Hello Adam,

Apologies for showing the wrong USBC adapter! Indeed I showed the USBC-7IN1E and not the USBC-7IN1 though insertion of the SD card should be similar. If you are still experiencing issues inserting the card at this time we would like to send you a new, pretested USBC-7IN1 under your warranty to see if we can resolve this issue. To start the replacement process would it be possible to contact us directly via email rather than through Discourse? To do this, please use your preferred search engine to search for “plugable support email”. This should get you to the web page with our direct email address.

In the subject of your direct email, please reference case 347794 which will allow us to match things up and then provide the next steps.

Apologies for the extra steps in the process, and thank you for giving us the chance to help!

Best wishes,


thanks for the awesome information.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.