USBC 6950U not working on my MacBook Air M2

Hello, I bought a USBC 6950U to use a dual monitor in my MacBook Air M2, it was working the first day and now it is not working, Any idea what could happen?

Hi Mauricio,

Thank you for contacting Plugable! I’m sorry the USBC-6950U isn’t working as expected, and I’ll be happy to assist.

The most common reason why USBC-6950U would suddenly stop working after working for a period of time on a MacBook is that the DisplayLink Manager is no longer running. The DisplayLink Manager is the software responsible for allowing the USBC-6950U to output video, and if the software is not running then the video functionality of the adapter would not work.

You should be able to tell if the DisplayLink Manager is running if its icon (looks like two interlocked rectangles) is present within the macOS menu bar at the top of your screen.

By default the DisplayLink Manager does not launch automatically when the MacBook boots, so it’s possible that the computer rebooting is the reason why it stopped running.

If it’s not running, you can start the DisplayLink Manager by following these steps:

  1. Open Finder and navigate to the “Applications” folder on the left side of the screen
  2. Locate “DisplayLink Manager” within the list of applications, and double-click on it to open it

Once the DisplayLink Manager is running the screens connected to the USBC-6950U should begin working.

You can also set the DisplayLink Manager to launch automatically when the computer boots. To do this, click on the DisplayLink Manager’s icon within the macOS menu bar, the check the box next to “Launch automatically after login”.

Please let me know how these steps work out, and feel free to ask if you have any questions.

My apologies for the frustration. Thank you for giving us the chance to help.

Plugable Technologies

Thanks a lot! this solved the problem, the DisplaLink manager was not active at login!

Hi I have the USBC 6950U and M2 MacAir, i am having trouble, have tried the workarounds and I can’t get any slave screens to display anything.

I opened display Manager App - selected “Launch automatically after login”. - re-booted, unplugged the USBC 695OU waited 20 seconds - plugged it back in to the USBC Port (blut light is on), still nothing.

  1. The Displink Icon is not showing at the top of the screen.

BTW I just found the ICON - it was hidden behind the Camera on the MacAir, but the slave screen directly hooked up to the MacAir displays it because there is no camera.

I am using HDMI cable tried swithing it between displays - still nothing displaying.

If i use USBC directly from MacAir port (bi-passing t695OU) one display works.

Hi Martin,

Thank you for reaching out. I’m sorry that the USBC-6950U isn’t working as expected in your setup as well. I’ll be happy to help get this figured out.

Based on your description of the behavior, our next step is to get some additional information.

Can you please send an email to our direct support email address ( with “For ticket # 423483” in the subject line? In the email, please include the following information:

  1. The Amazon Order ID number for your docking station purchase
  2. While the USBC-6950U and displays are connected to your Mac (even if not working as expected), the output of our diagnostic utility PlugDebug:

This information will help us to determine the next steps.

** Please do not post the above information here in our public forum (it contains personally identifiable information) **

Apologies for the frustration, and thank you for giving us the chance to help!

Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.