USBC-11INE stopped working with 2 4K displays

Hi, I’ve been using this dock with my Dell XPS 9520, it worked perfectly with 2 4K Dell monitors. But it just stopped working a week ago. I tried updating all the drivers.

Each monitor still works independently, but if I plug both of them in, one of them switches to 1920x1080.

Would love any advice,

thank you!

Hi there!

Thank you for contacting Plugable support. We would like to take a closer look at your system to better help assist but require some additional information. Instead of posting that information here, could you please contact us directly via email? To do this, please email us at In the subject of your direct email, please reference case #420645 which will allow us to match things up and then provide the next steps.

Apologies for the extra steps in the process, and we thank you for giving us the chance to help!

Best regards,

Michael S.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.