USB3-SATA-UASP1 drive disappears after a few seconds


#1

I got a new mini-computer and tried to connect one of my Plugable SATA Docking Station (USB3-SATA-UASP1) to it.
It looks fine at first, the drive appears and I can see the content but after about 10 seconds, the drive disappears. The same hard drive, inserted in an older StarTech docking station works fine.

During those 10 seconds, I can see in Device Manager that a “USB Attached
SCSI (UAS) Mass Storage Device” appears under “Storage controllers” but then disappears.

I’m running Windows 10 Pro with all updates installed.

What else can I do to troubleshoot?


#2

Hi…is the second SATA drive you acquired used or new? Is it SATA 3 ?Make/model of PC and second HD please?Have you tried different SATA ports, cables?
Whoever tries to resolve this for you will need that info.Could be your controller, smells like the disk though. If its the controller you will be replacing the mobo.

pcba prototype


#3

The computer is a MINIS Forum Fanless Computer Z83-F

https://smile.amazon.com/dp/B07JQ7ZC29/ref=cm_sw_r_tw_dp_U_x_Wq2tCbJSFDEDV

I’ve tried 3 different hard drives and at least 3 different USB cables.
All the hard drives and all the cables work fine when connected to another computer (Lenovo Laptop) through its USB 3.0 port.

Things also work fine when connecting the Plugable SATA dock to the USB 2.0 ports of the Z83-F.

Basically, the only specific combination that doesn’t work is the Plugable SATA dock with the USB 3.0 port of the Z83-F.

So I figured I’d try another USB3-SATA-UASP1 I have lying around (I’ve bought many through the years) and that one seems to work fine. To make sure it wasn’t a badly plugged cable, I’ve swapped the two USB3-SATA-UASP1 a few times and sure enough, one of them always disconnects when plugged in to the Z83-F but works fine with the laptop. The other plugable works fine with either computer.

Is it possible that my two USB3-SATA-UASP1 have different firmwares in them?

One difference between the two is that the non-working Plugable appears in device manager (under Disk drives) as "ASMT 2105 SCSI Disk Device" for a few seconds and then disappears.

The working one shows up as "Plugable USB3-SATA-UASP1 SCSI Disk Device".


#4

Since my last post, I have discovered this page
https://plugable.com/drivers/hddockfirmware

Using the check utility tool it includes, I was able to get the firmware version of the three USB3-SATA-UASP1 docks I scrounged up.

They are:
Dock A: 130107917d00
Dock B: 121026910000
Dock C: 130107917d00


#5

I upgraded the firmware of dock B (the troubled one) to 130107917d01.
Since the other working docks had 130107917d00, I had high hopes it would solve the problem, but it didn’t. The drive still appears and disappears.


#6

Hello,

Thanks for contacting Plugable Support! My name is Jordan and I am happy to help. Sharing this quick guide on external hard drive dock troubleshooting for any other future readers with similar symptoms:

The fastest way to isolate the cause of the issue will be via the following troubleshooting steps:

  • test the same hard drive and Plugable dock in a different computer
  • test a different hard drive with the same Plugable dock and computer
  • test a different USB cable with the Plugable dock if you have one available

Also, we know that the hard drive is working OK in your StarTech dock. Sometimes, a hard drive with existing data could be formatted in a non-standard way that means it can only be read in its last known good location.

So if that last known good location (StarTech dock) is still available, you could also 1) return the hard drive to the last known good location, 2) back up any important data, then 3) reformat the hard drive in a standard way like NTFS with Advanced Format instead of any type of proprietary sector emulation. Then your drive should be recognized in any other hard drive dock.

Since you have tested the Plugable dock with multiple variables (different hard drives, USB cables, USB ports, and computers) and also have similar Plugable docks that are not experiencing the issue, this most likely points to a defect of some kind with that particular Plugable dock unit.

Please contact support@plugable.com and we can run a debug tool to see what options are available to resolve this issue. Usually that’s either with a remote fix or replacement unit under the Plugable hardware warranty.

Hope this helps!

Thank you,
Jordan
Plugable Technologies


closed #7

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.