USB3-SATA-U3 USB 3.0/2.0 SATA Hard Drive Docking Station Cannot Read Drive


#1

Plugable USB3-SATA-U3 USB 3.0/2.0 SATA Hard Drive Docking Station, problems recognizing a drive with existing data on Windows 8 and Windows 7 machines. The problem seems to be the one described in “http://plugable.com/2013/03/05/usb3-s…”, but this fix does not seem to work. When applying firmware update, “FAIL” at “RELINK” step, however, subsequent checks show that …f602 has been applied. Dock shows up in system devices, but any attempts to see the hard drive have failed so far. The FAQ issue “My drive is spinning, and detected in disk manager/disk utility, however I get an error about needing to initialize the volume- even though there is already data on my drive” does describe my problem.


#2

Hi Jon-

Thanks for posting with your issue, I’ll be happy to help.

1st, as to the fail on re-link- this is likely due to the issue described below, or is expected if no drive is in the dock when flashing (as re-link is testing the connection to the drive in the dock, AFTER the update is successfully applied).

Is it possible this drive was initialized (had a GUID/GPT or MBR partition table) using the USB3-SATA-U3 -before- you updated the firmware? If that’s not the case, could you please share some details about how the drive was setup or what it was used in previously?

Once I have this extra detail I’ll be able to recommend our next steps.

Best wishes-

Jeff Everett
Plugable Technologies


#3

Thanks for getting back to me. Now I have some concern that the drive is simply no good, but unfortunately I don’t have any way to confirm this since I don’t have another SATA drive to test in the dock. This was the primary drive on my desktop computer, which stopped booting to Windows. My intent with the dock was to get data off the drive and possibly reformat it for a reload.

The drive is definitely set in the dock, as I can hear it spinning (at times). I believe the firmware update took because checks show that the 602 update is applied. I believe that the dock is connected ok to the laptop because it’s showing up in the devices list with no errors. I’ve tried both the USB 2 and 3 cables and get the same results. I’ve tried using the dock on two different computers (Windows 7 and Windows 8) with the same results.

In Windows 8 if I go to the device manager and select the dock properties and go to the Volumes tab and “populate”, the disk is seen, but type is unknown, not initialized, capacity 0, etc.

I go to disk management, get the partition dialog and select OK for GPT partition:
“The specified disk is not convertible because the size is less than the minimum size for GPT disks.”

Select OK for MBR partition, “The device is not ready.”


#4

Hi Jon-

Thanks for the background information.

Given that the drive quit booting Windows, I think there’s a good chance this is why it’s also not recognized in the dock.

I would recommend seeing if you can find another known good SATA disk to borrow and double-check that the dock works. Another option is to try the drive in a different PC/SATA controller.

Please don’t hesitate to let me know of any other questions. As a last note, so long as the ASMedia firmware version check utility is showing the firmware version for the dock, it is unlikely that the dock itself is the source of the issue (given current information):
https://s3.amazonaws.com/plugable/bin…

Sorry I can’t offer a more helpful answer here but this sounds like a drive failure. We can try a “wipe” or “clean” procedure to completely erase the drive, however this would destroy all your data, and that doesn’t sound like a good option in this case.

Best wishes-

Jeff


#5

Thanks, I will do some more digging in the next few days and try to confirm. I appreciate the information and quick response.


#6