USB3-HUB7A Not Recognized after update to El Capitan (late 2012 iMac)


#1

USB3-HUB7A worked fine on late 2012 iMac under Mavericks, but no lights, no joy after update to El Capitan. Purchased after mid-September 2013, so should have the VL812 B2 chipset with firmware version 9081.


#2

Hello,

Sorry about this issue. Have you already tried unplugging the hub from USB and power, then reconnecting power first and USB last? Sometimes a power cycle is all that is needed.

If that doesn’t work, if you have a Windows computer with USB 3.0 available to use for a short time, you can update the firmware on your hub:
https://s3.amazonaws.com/plugable/bin…

If you don’t have access to a Windows PC with USB 3.0 just let me know.

Thanks,
Josh


#3

Thanks for the response. It seemed silly at first, but in the process of recycling the power/plugin, I discovered that the power/breaker switch had tripped (I had previously just verified that the power supply brick had green light). However, I did go ahead and connect to a PC with USB and updated FW from 9081 to 9091, then reconnected to iMac and now all is well. Thanks!


#4

Glad to hear it worked out!

If you need anything else just let us know.


#5