USB3-HUB7-81X Windows 10 System Service Exception


#1

I have the Plugable USB3-HUB7-81X and it initially worked fine for about a month but only if I plugged the device in after my PC had booted. If I had the hub plugged in when booting the PC, I would receive the error SYSTEM_SERVICE_EXCEPTION (asmtxhci.sys).

Now whenever I even just plug the device in, whether I’m booting for the first time or the PC is already in Windows, it blue screens and throws the above error message. I tried scouring the internet and these forums but I could not find any answers. I have the MSI Z170A GAMING M7 ATX LGA1151 Motherboard as I feel the driver compatibility from this Motherboard, Windows 10, and the USB Hub could be the source of the issue.


#2

Hi Nate,

Sorry to hear about this issue. It does sound like a driver issue.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

I can then take a look at the drivers currently installed and see if I can make a recommendation.

Thank you,
Joshua Henry
Plugable Technologies


#3