USB3-HUB10C2 Doesn't seem to work with USB 2.0 devices on linux (XHCI) when connected to USB 3.0 port on host


#1

I have a Plugable USB3-HUB10C2 that I bought a few days ago from Amazon (order id was 114-1676871-4001037). I have the hub connected to a USB 3.0 port on my computer running Ubuntu Trusty (14.04) fully updated and running the latest 4.3.0 kernel.

The hub doesn’t see any USB 2.0 devices (2.0 not 3.0). Examples include:

  • YubiKey
  • ACR122U USB NFC reader
  • Sena UD100 BTLE dongle
  • C-Media Electronics, Inc. CM108 USB sound card

All these devices work properly when connected to a USB 2.0 port on the host or through a (different) USB 2,0 hub.

The devices also do not work when connected to the Plugable hub through an additional USB 2.0 hub.

When the Plugable USB 3.0 hub is connected to a USB 2.0 port on the host computer all the devices work.

In SOME cases, I _THINK_ I saw a libusb error related to BULK TRANSFER FAILED.

I have also tried with a different USB 3.0 PCI-E card using the NEC uPD720200 chipset, with the same results.

The lspci -v output for the host USB 3.0 controller is:
02:00.0 USB controller: Renesas Technology Corp. uPD720201 USB 3.0 Host Controller (rev 03) (prog-if 30 [XHCI])
Subsystem: Renesas Technology Corp. uPD720201 USB 3.0 Host Controller
Flags: bus master, fast devsel, latency 0
Memory at f9bfe000 (64-bit, non-prefetchable) [size=8]
Capabilities:
Kernel driver in use: xhci_hcd

[/size]


#2

I received a helpful answer from Patric at plugable. The problem seems to be with my Renesas XHCI host coltroller or the interaction between the Renesas controller and the plugable USB 3.0 hub and/or the USB 2.0 devices.

I need to look for a better USB 3,0 host controller - suggestions and pointers to cards that are known to work well in Linux are appreciated.


#3

Some more updates on this problem:

The plugable USB 3.0 HUB does work with my Renesas USB 3.0 controller. There may be some issue that requires the hub to be powered down and powered up when moving the upstream connection to a new (type of) controller. Once the hub is power-cycled, it detects ALL BUT ONE of the USB 2.0 devices I tested.

The one device that consistently doesn’t work when the plugable hub is connected to my upstream Renesas USB 3.0 controller is an SCM Microsystems Inc. SCR 3310 smart card reader. This device doesn’t work even when connected directly to the upstream Renesas USB 3.0 controller (same behavior as with the plugable hub).

This needs further investigation and my conclusion is that it is not related to the plugable USB 3.0 hub.

The other devices I listed (ACR122U USB NFC Reader, CMedia USB sound card, Sena USB BTLE dongle, Yubikey) all work.


#4

I have tried this card on another machine that has an onboard Intel USB 3.0 controller and this card DOES work there.

So, the conclusions are:
The plugable USB 3.0 hub works, including with my Renesas USB 3.0 controller
The SCM Microsystems Inc. SCR 3310 card works, including with a USB 3.0 controller - just not with the Renesas controller


#5

We replied via email directly several days ago, did you get our response?

Just wanted to touch base since we missed your replies here.

Thanks!


#6

I’m going to close this thread, if you need any additional support contact us at support@plugable.com


#7