USB3-E1000 + Win7 VM (not working)


#1

Hello, I just purchased Plugable’s USB3-E1000 1G USB-to-RJ45 Ethernet adapter. My intent was to connect this to a Win7 VM to provide the VM a dedicated path to the network, rather than having the VM’s virtual NIC NAT or bridge through the host machines NIC. In essence this provides me “two real laptops in one” which is great for testing things like 802.1X authentication with one machine acting as a network client and using the other machine to watch the RADIUS authentication logs on the server side of things at the same time.

Upon trying to connect the USB-to-RJ45 to the Win7 VM, I get the following error message: The device “ASIX AX88179” was unable to connect to its ideal host controller. An attempt will be made to connect this device to the best available host controller. This might result in undefined behavior for this device.

I had read that this adapter was 1G, USB 3.0, and compatible with Win7/Mac. This was the “perfect combo” I was looking for when shopping for the adapter. It works great on the Mac (the host machine) but not on the Win7 VM. I really need this to work on the VM. Can anyone help me out? Thanks!


#2

Hi Dan-

Thanks for posting with your issue- and great details on your setup and goal- I’ll be happy to help!

It sounds like there’s an issue with the USB 2/3 identification of the device, or something around this. My best guess is that this is an issue with the USB 3 host controller driver provided by your virtualization platform. Disabling usb 3.0 mode and using the device as a 2.0 device might be a good way to help verify this. The host controllers are the USB host controllers, which are a function of your hypervisor or virtualization platform such as Parallels, VirtualBox, VMware Fusion/Player/etc, so they’ll be found in you’re VM’s settings in whichever hypervisor you use.

Can you please share some further details on how you’ve setup your VM? A screenshot of the error you’re seeing would also be helpful. ctrl+shift+3 captures full-screen snaps straight to the desktop in OS X. With a little more detail on the VM and it’s virtual environment I’m confident we can get your VM it’s dedicated line.

Best wishes-

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies


#3

Hi Jeff -

Thanks for your reply, that was quick. I actually got it last night but was too tired to muck with it anymore, needed sleep. Background, I’m new to Mac. I was issued a corporate laptop running the latest Mac OS X and VMware Fusion, this is my current setup. In the past I’ve run Win7 desktop with VMware Workstation for any VMs I needed to accomplish the same goals but this is a little different. So thanks for the info because I never realized before (in either setup) that there were different USB modes I could run in the VM. So I went digging.

I found that my VM was running USB 2.0 compatibility mode (this made sense as I had already tried a different USB 2.0 device successfully). Figuring this might be the problem since I’m now trying to use a USB 3.0 device, I figured your advice above was ‘opposite’, so I enabled USB 3.0 mode. When I plug in the USB3-E1000 now, I see the Windows Device Manager trying to install a new USB Controller but trying to install this using Windows Update fails. I already ran the following file: 2013-03-Plugable-ASIX-USB-Ethernet-Windows-Universal.exe on the Windows VM prior to plugging in the adapter, so I figured I’d have everything I need. Apparently not. I also plugged the old USB 2.0 device I mentioned above in with the same results, the device no longer works.

I tried taking a screenshot of all of this with your instructions but I think my keys aren’t mapped the same or something because I find no snaps on the Mac desktop.

So anyways, I’d agree with your diagnosis of the problem. The question is… what drivers do I need to support the new USB Controller that is being installed in USB 3.0 mode as a result of plugging in the USB3-E1000 and where can I get them?

Thanks,

Dan


#4

Hi Dan-

You’ll need to contact VMWare about this issue: since the USB 3.0 host controller drivers for the virtual machine come from them, this is an issue we’re not able to help much with.

I suspect you may find that this will only currently work in USB 2.0 mode, however if any updates to the VMWare Fusion USB 3.0 host controller drivers are available, VMWare will be the the best place to find out.

Sorry I can’t be more help here, I hope this at least points you in the right direction.

Please let us know if you’ve any other questions!

Best wishes-

Jeff


#5

Will do Jeff. Thanks again for the help. Just for last clarification, should the USB3-E1000 fall back to USB 2.0 with that support enabled in the VM? Because that fails…

I will check with VMware for drivers.

Dan


#6

Hi Dan-

Indeed USB 2.0 fallback mode should be automatic and transparent: you shouldn’t know it’s happening without being savvy enough to check.

While I don’t mind taking a look into the state of things on Fusion, I’d anticipate you’ll have access to their support resources who might be better informed on the current state of affairs there. USB 3.0 emulation for VM’s across hypervisor platforms is one of the parts that’s still very much under development, only a recently added feature in most.

Don’t hesitate to let us know if you have other questions.

Best-

Jeff


#7

Yeah. USB 2.0 fallback in Fusion isn’t working.

I did some poking around on VMware’s website and it looks like this has been going on a while. I also found reference material saying that USB 3.0 in VM Fusion requires Win8 (no support for WIn7). Drat!
http://communities.vmware.com/thread/…

So then I decided to just plug USB3-E1000 into my Win7 desktop (no VMware, no hypervisor, etc). I loaded the driver pack I downloaded from your website first. The adapter connects, loads driver, and I even see a NIC added in the Network Properties screen. But even when I plug a cable into the adapter I get nothing… it reports that there is no connection. Also, if I do an ‘ipconfig’, same thing the adapter doesn’t show up in the output list.

Now, I can understand the hypervisor layer maybe not having a driver as you explained, but native Win7 by itself? That is listed as being supported on your webpage. Is it not? If it doesn’t work in native Win7, I don’t really see any hope of it working in the hypervisor. Please advise.

Thanks,

Dan


#8

Hi Dan-

Just to be clear yes, Windows 7 is supported. It is possible that there is some device specific-issue that is manifesting only on Windows, not on OS X.

Also, the device should “just work” if you installed the driver before plugging it in. It sounds as though there may be some driver installation issue here worth investigating. Does device manager list the AX88179 device under network connections or unknown devices? Any error codes listed in device manager (windows key + r, type “devmgmt.msc” without quotes, press enter) would be most helpful here.

This should be a solvable issue with this additional detail.

Best wishes-

Jeff


#9

Hi Jeff -

Sorry for the delay. Yes, I installed the driver on Win7 desktop (not VM) prior to plugging in the device. Yes, the Device Manager shows the AX88179 device listed under network connections. If I view the properties of this device, Windows reports that this device is working properly. There are no error messages or codes. I have tried disabling and re-enabling the adapter as it appears in Network Connections, I’ve ensured it’s the only device with “link/connectivity”, I’ve rebooted my Win7 workstation, and I’ve ensured the adapter has a green link light and activity on the orange light when plugged in. The only problem is the device does not show up in ‘ipconfig’ output or appear otherwise “plugged in” from the Operating System perspective. In Network Connections, the adapter appears as any other adapter would that does not have a cable plugged into it (even though in my case, there is a cable plugged in as already described).

Thanks,

Dan


#10

Hi Dan-

Sorry to hear none of the standard networking troubleshooting steps helped.

If you haven’t already tried uninstalling the device from device manager (make sure to choose the option to delete driver software), I would try doing this and then giving Windows Update a chance to install drivers automatically.

The only other quick troubleshooting step I can think of would be to try different USB ports on your PC and/or removing any hubs you’re connecting through and trying a direct connection instead.

If that doesn’t help, could you please send your ipconfig /all output in a mail to support@plugable.com with a link to this thread?

Best wishes-

Jeff


#11

Thanks. I have an Asus P7P55D motherboard, which only has USB 2.0 plugs on it. So it should fall back. Uninstalled, reinstalled, let Windows Update find the drivers. Drivers install, Device Manager reports “device is working”, adapter shows up under Network Devices (Local Area Connection 4), cable is plugged in lights are on but nobody is home, no ‘Local Area Connection 4’ shown in ipconfig output.

Emailing support. Thanks again for your help.

Dan


#12

I have a Dell XPS 13. I have installed the latest drivers from the plugable website. It works fine once you logon to the laptop. I am trying to boot from network to create a WDS Image. This does not work.

Can you kindly assist on this please?


#13

I’m not sure how that relates to this particular topic/post, but OK.

Network boot is typically a function of your BIOS. In the case of ‘system BIOS’ the network boot setting would likely use a built-in Ethernet adapter for network boot (aka, on the motherboard). In the case of ‘adapter BIOS’ (like an iSCSI network adapter) the network boot settings would likely not be found in the system BIOS but in the adapter BIOS itself and would use the local port on the peripheral card for network boot.

I’m not sure if you’d be able to network boot from the USB-to-RJ45 converter. I’m not sure why not I’m just unsure of the proper settings. There is also a boot from USB, but typically I think this expects a bootable volume (like a hard drive) to be found on the other end of the USB cable, which your converter will not have. So boot from network is probably the appropriate setting. I would contant Pluggable support to find out if this type of network boot is supported with their adapter and then for instructions on how to go about setting that up.

Cheers.


#14

This is a great conversation that’s separate from the main topic, so I created a new topic to continue the discussion.

Please reference the new topic here: Can I use a USB network adapter for boot-time PXE scenarios?

This boils down to whether the UEFI or BIOS on the target system you are trying to capture from has support for the chip used in the USB network adapter in question. In the vast majority of cases, this will *not* work. Details on how to check are discussed briefly in the new thread linked above, and details on why this won’t work are here: http://plugable.com/2013/10/27/suppor…


#15