USB3-E1000 will not stay connected to my Dell XPS 13 running Windows 10


#1

USB3-E1000 will not stay connected to my Dell XPS 13 running Windows 10! It disconnects and reconnects every few seconds and makes it impossible to use. I have reinstalled the drivers, changed adapter and usb settings and nothing will correct the issue.


#2

I have the same problem. eMachines e725 win10

I removed Norton security and it seemed to help but it is still happening.


#3

I have just discovered that if you plug the adapter into the USB port on the left of the keyboard all works fine whereas on the right-hand port it continuously connects and disconnects


#4

Hi Barry and Charles - Dell has a KB article on this issue with the XPS 13 that may be helpful: http://www.dell.com/support/Article/us/en/19/627261/EN


#5

Hi Bernie - Thanks for your information which is very helpful. For some reason my XPS13 functions differently even though I have NOT made the modification suggested in the KB article from Dell. The left hand USB port works fine but that on the right give all the problems.


#6

Interesting! Thanks for that extra info!  Robb - is the behavior you’re seeing with your XPS 13 the same as Rob’s (or the same as the KB’s)?


#7

I also notice that the Bios settings on my model (which is very recent) of the XPS13 is different from that set out in the Dell KB and the left hand port is now described as a USB3 port and that on the right is described as USB3 with powershare port.


#8

I was experiencing the same problem on all Ports. The powershare port is a different form factor (USB-C) on the left side of the chassis and the USB3-E1000 does not plug into that port.

I have received a replacement adapter and my disconnects of reduced from every few seconds to once an hour. Not ideal, but I can live with that.


#9

Barry and others - contact us at support@plugable.com and we can try the same thing as with Robb, I’d like to know if it helps in other cases or not. Thank you!


#10

My Dongle now seems stable. I think part of the issue for us is that there are a number of models of the XPS13 including a new model in the last month or so which is the stable from which mine has come… Mine is an XPS13 Model 9350 which has three USB-like ports (1 x type C Thunderbolt 3 and two USB3’s . My USB3 on the left is the only one which will run happily with thye dongle. The USB3 port on the right is a USB3 with Powershare which allows charging of devices while the computer is off.

I am very happy to try a different dongle if I can be helpful.but luckily my issue has been solved.


#11

Great to know, thanks Barry!


#12

I’m having the same problem with XPS 15 9560 model using Plugable USB3 hub with Gigabit Ethernet. Connection stays up for a short while and then dies.

However, if I connect via my monitor (which has a USB3 hub) everything works without any issues. This seems to be an incompatibility between the Dell XPS USB3 hub and Plugable hub.

I’ve tried disabling all power saving options to no avail, the problem persists if the hub/ethernet is connected directly to (either of the two) USB port on the Dell.

Any suggestions to fix this, or should I just return the product to Amazon?


#13