USB2-Switch2 Disconnect Issue on Mac OS


#1

Using USB2-Switch2 with an attached 4-port USB hub, keyboard and mouse attached to said hub. Works fine every time with Windows 7, however, Mac OS X 10.8.2 occasionally refuses to recognize the connected devices. Plugging hub directly into computer works fine, the switch is the issue. A restart fixes the problem for a variable length of time, sometimes hours, sometimes days. Weird. Got anything for me?


#2

Hi Caleb,
Thanks for contacting us about this issue. It is strange behavior and it sounds frustrating.

Have you tried the Mac on both sides of the switch and experienced similar results? Also, could you try switching cables to see if one of them might be causing the problem?

Thanks,
David
Plugable Support for


#3

Yes, on either side of the switch the behavior is the same. Switching the cables yielded the same result. It’s not a terribly easy bug to reproduce as it is rather unpredictable. However, it TENDS to happen after several switches in succession (say switching back and forth 2-3 times). And once OS X has lost the switch, unplugging the hub and replugging it works maybe 30-50% of the time. If that fails, I have to either plug the hub directly into the computer and bypass the switch, or restart the computer entirely.


#4

Hi Caleb,

Thank you for trying that. One more thing. Could you try the switch without the hub (with the keyboard or mouse plugged directly into the switch) just to eliminate the hub as a possible problem?

Thank you,

David


#5

I will try to reproduce the bug with this configuration. Will let you know if it happens.


#6