USB2-e1000 adapter not connecting under OS X 10.9 Mavericks


#1

After upgrading to OS X 10.9 Mavericks based on assurances that my adapter would work, I’m finding that I’m not getting an IP address. I have DHCP at my university and it worked fine under 10.8 Mountain Lion. (My USB3 hub from Plugable is working fine, so it’s not a brand issue, it’s an adapter issue.)

I have repaired disk permissions, as pointed out somewhere, and I have made sure that I don’t have any drivers installed. I would install drivers, but I’m told that 10.9 Mavericks should take work with this adapter. I’m wondering if there’s something else I can do. Any help is appreciated, and I’m happy to give more information, if needed.


#2

Well, so much for worrying about installing the driver - I did it anyway (there’s always the uninstall option), and it worked for me. Thanks for keeping these drivers around!


#3

Hi Michael-

Thanks for posting!

I just did a quick test on the final version of Mavericks that came out yesterday, and found that 3 of our USB2-E1000 units worked with no issues with the Apple driver built-in to 10.9- so I think there’s something unique to your system here.

One step I’ve frequently seen help is removing and re-adding the network adapter under network preferences. Can you give that a shot and let em know if it helps?

If it doesn’t please shoot a mail with a link to this thread and the output from our support tool, PlugDebug, attached to support@plugable.com. Instructions to download and use PlugDebug are here:

http://plugable.com/support/plugdebug

The additional details will help us get this sorted out- any other questions, just let me know!

Best wishes-

Jeff Everett
Plugable Technologies


#4

Hi Michael-

Thanks for letting us know the driver worked!

I think this option should be fine, but let us know if you hit other issues!

Best-

Jeff


#5

same here - the adaptor works perfectly well before updating to Mavericks, but it says “Self assigned IP” after the update - doesn’t work anymore


#6

Hi Kelvin-

Thanks for posting, sorry to hear about your issues after updating.

Steps to resolve will vary with a couple of different factors on your system. Can you please shoot an email to support@plugable.com with the output from our PlugDebug support tool? The additional details it provides on your system will help us provide the right steps.

Instructions to download and use PlugDebug are at http://plugable.com/support/plugdebug

If you can also please open a terminal window and enter the following command, and copy and paste the response from your system into your email to support@plugable.com this will be most helpful:

ls -alh /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/

Best wishes-

Jeff Everett
Plugable Technologies


#7

Michael- thanks for sharing your experience.

Other users- if you need something that works, the ASIX 4.0 driver works (as did 3.10)- but we’ve seen issues after uninstalling this driver, and are waiting to hear if/when ASIX will have a signed version- so we’re holding off on distributing this publicly for now, and recommend customers avoid installing if possible.

For those adventurous ones who forge ahead with the ASIX 4.0 driver, please comment here on your results.

Best-

Jeff


#8

tried the instructions but still doesnt work :frowning:


#9

For any users following this thread, please note the updated official response detailing different behaviors expected on early adapters with serial numbers beginning 5,6,7 VS newer units with serials beginning 8,9,10.

Best-

Jeff


#10

For any customers hitting issues with the USB2-E1000 on Mavericks, please note that while updated ASIX drivers are available, as the OP has stated, and seem to work well, we are not yet recommending these drivers since they are not signed, and are not necessary for most users.

Please note that users with older Plugable USB2-E1000 adapters with serial numbers beginning with 7 (and possibly some beginning with 5 or 6), will not be able to use Apple’s in-box driver. These users may install the latest, unsigned, ASIX driver from the link below:
https://s3.amazonaws.com/plugable/bin…

For users with newer Plugable USB2-E1000 adapters with serial numbers starting with 8, 9, or 10, he following steps are recommended for initial troubleshooting:

  1. Uninstall the ASIX driver using the uninstall script packaged with the driver installer.
  2. Disconnect the USB2-E1000 adapter and set it aside.
  3. Remove the interface from network preferences.
  4. Use the OS X repair disk permissions tool- terminal command:
    diskutil repairpermsissions /
  5. Reboot, log back in.
    6 Reconnect USB2-E1000- check if interface was automatically created in network preferences, add manually if not.

Should these steps not succeed, please send a mail to support@plugable.com including a link to this thread and:

  1. The serial number of your adapter
  2. The output from our support tool, PlugDebug.

Instructions to download and use PlugDebug are at:
http://plugable.com/support/plugdebug.

Best wishes-

Jeff Everett
Plugable Technologies


#11