USB2-E100 stopped working after a day on Microsoft Surface


#1

Hi,

My company ordered one of your USB2-E100 ethernet adapters from Amazon toward the end of last week and we received it yesterday. We purchased it so that we could hook up a Microsoft Surface (the ARM version) to our internal network to perform remote debugging via Visual Studio.

When we received the adapter, I installed the appropriate drivers and then plugged in the adapter. It was immediately detected and installed and seemed to be working fine (I was able to successfully connect to the Surface from Visual Studio and launch apps connected to the debugger). At the end of the day, I left the adapter plugged into the Surface when I left the office.

The next day (today), I woke up the Surface and attempted to connect to it again and found that it was not working. Looking at the adapter, I noticed that neither of the LEDs were on and no link or activity lights were on on the switch port that the adapter was plugged into. I tried unplugging the adapter from USB and plugging it back in, unplugging the adapter from ethernet and plugging it back in, and uninstalling it from the Device Manager and reinstalling it. Nothing seemed to work. When the adapter is plugged in, Device Manager does detect it, but it shows a status of “This device cannot start. (Code 10)”.

I also tried plugging the adapter into my desktop machine (which is running Windows 8 Pro). This adapter was detected and the drivers were automatically installed, but Device Manager shows the same “This device cannot start. (Code 10)” as the status.

Since the adapter is detected in Device Manager, it seems like it might just be in a bad state. Is there some way to reset it? Or is it possible that we just received a faulty adapter that died after a day?

Any help you can give would be appreciated.

Regards,

Nathan.


#2

Hi Nathan,

Thanks for posting here! Just shoot us an email at support@plugable.com with your Amazon Order ID along with a link to this thread and we will take care of the issue.

Regards,
Roze


#3