USB2.0 to Fast Ethernet Adapter has a driver problem" in Windows 7


#1

Cannot get the Ethernet connection to work. Tried reinstalling the driver through Windows Troubleshooter and get message: “ASIX AX88772 USB2.0 to Fast Ethernet Adapter has a driver problem” in Windows 7. Looked under the driver in properties and it has the status of “This device cannot start. (Code 10)”


#2

Hi Corey,

Sorry the adapter is having a problem on your system! We’ll be able to solve the problem.

There is a different driver depending on whether you’re running 32-bit or 64-bit Win7. The most common source of this code 10 error is installing the 32-bit version on a 64-bit system or vice-versa.

So let’s use ASIX’s combined installer that has both 32 and 64 bit drivers installed. We’ll get the latest driver direct from ASIX:

  1. Install a program to uncompress .rar files (we recommend http://7-zip.org/ )

  2. Download the ASIX 88772 Win7 combined 32/64 installer here: http://www.asix.com.tw/FrootAttach/dr…

  3. Right click on the .rar file you just downloaded, choose 7-Zip->Extract files…

  4. And then run the setup program in the location where you extracted them

Let us know if you have any trouble at all. Thanks for your patience!

Bernie


#3

I tried this and get the same error. This new driver has a 5/31/10 date. Is this correct?


#4

Hi Corey,

Yep, the driver package has a Sept 2010 date, and the driver inside a May 2010 date.

If that’s the driver, and the install completed successfully, and you’re still getting the code 10, then we have a different kind of issue. Thanks for confirming that’s the case, and we’ll do a little digging to try to figure out what it might be and next steps.

Thanks for your patience!
Bernie


#5

Hi Bernie,

Haven’t found anything yet?

Currently, I’ve plugged my network cable directly in the PC for now. Everthing else works great - monitor, keyboard and audio. My mouse is running of bluetooth. So, it is not using the docking station.

Corey


#6

hello, someone could tell me where to find drivers for usb connector intenet called : USD2.0 TO FAST ETHERNET ADAPTER HZ .

THANK YOU.


#7