USB-VGA-165 works then stop working


#1

I use the USB VGA adapter(for a 3rd display) on a HP laptop running Win 7 Home Premium 64 bit for about a year. The 2nd display is connected to the VGA port of the HD 6550 video card.

Starting last week, it was acting up. Basically, windows can’t see or extend to the 3rd additional display. I reinstalled the driver 5.6M2 (also tried the latest 6.3), and it worked again once, each time right after new driver is installed.

As soon as I reboot the machine, it didn’t work agan. It seems to work best the first time when the DisplayLink Manager recognized the new display and installed the driver.

I checked these

  1. The displayLink Manager is running, under Services and under Task manager

  2. Under Device manager, you can see USB Display Adapters - Plugable USB-VGA-165 - its Hardware Ids are USB\VID_17E9&PID_037B&REV_0101

But during one of the subsequent USB device driver installed (when plug in), I could see it as DisplayAdapter(8060) installed in the popup, which indicates it may have some kind of problem loading the driver.

  1. I have tried both the 5.6M2 as recommended on Plugable page and the 6.3, the latest driver from DisplayLink which also supposes to work. I unplug the USB, went to add or remove programs to uninstall DisplayLink software and then use the download to install it back before plugging the USB back in.

Both works ONCE… the very first time after you installed the driver and plug into the USB.

  1. I have also change cables, monitors and the problem is repeatable.

Any clue?


#2
  1. I uninstall the USB-VGA-165 adapter within device manager. Unplug the USB, shutdown, start up the machine, then plug the USB back in. It searches for driver via windows update and got the 5.6 driver and bring the 3rd display back to work.

#3

Hi TT,

Thanks for posting here! I’m sorry to know about the trouble you are having. Let’s figure out what is causing the issue and how to resolve it.

We do not recommend using the DisplayLink 6.3 drivers as we are aware of various issues caused by it. Our recommended DisplayLink driver for USB 2.0 is 5.6M1 as it is the most stable version for DisplayLink based USB 2.0 Graphics Adapters.

If the current version of driver installed on the system is 6.3, I’d recommend uninstalling it and installing the 5.6M1. Here are the steps to do that:

  1. Make sure that the Plugable USB-VGA-165 is unplugged from the System.

  2. Click on the following link to download the DisplayLink install cleaner.
    DisplayLink Install Cleaner

  3. Once the download is complete, unzip the downloaded file and run the DisplayLink install cleaner. Reboot the system.

  4. Download the DisplayLink driver 5.6M1 from http://www.displaylink.com/support/sl… by clicking the ‘Agree’ button and run it to install this driver.

  5. Connect the Plugable USB-VGA-165 to the System .

If you continue to see issues even after the Displaylink 5.6M1 driver is installed on the system, please run the DisplayLink support tool (instructions here: http://plugable.com/support/displayli…) and email the resulting .zip to support@plugable.com along with your Amazon Order ID and a link to this thread.

This will give us a better insight as to what is going on and help figure out next steps.

Regards,
Roze


#4

Hi Roze,

I used the Install Cleaner, reboot,then install the 5.6M1 driver. It works the first time.

Then, I reboot, and got Device driver software was not successfully installed.

Unknown Device X Failed.

The only thing I did was shutdown and power the laptop up.

I am going run the support tool and send you guys the file.

Why would the driver stop working after reboot?


#5

I noticed the DisplayLink Core Software is 5.6.31854.0 while the DisplayLink Graphics is 5.6.31870

I have checked to make sure to service and the software were cleaned after the Install Cleaner.

And after reboot, the device manager no longer recognize the USB-VGA-165 USB display device… and just named it unknown device.


#6

TT,

Please do run the DisplayLink support tool (instructions here: http://plugable.com/support/displayli…) and email the resulting .zip to support@plugable.com along with your Amazon Order ID and a link to this thread.

We will figure out what is the root cause and take care of the issue.

Regards,
Roze


#7

Yep, I just sent it.

I also noticed after a few reboots. Unplug and replug, it was trying to find the USB driver, couldn’t find it, then went online and get 6.1 all without my help.

The Graphics software is still 5.6 but the Core went to 6.1

Needless to say, I just ran the cleaner again.


#8

How come I see the DisplayLink Manager icon on the task bar sometimes but not other times?

Is it supposed to be there all the time? Or does it only show up during the first time setup?

Basically, when I see that icon, it means the USB device is recognized correctly as a display adapter and 3rd display is connected and I have control over it. I just can’t figure out why it shows only some of the time.


#9