USB to VGA Adapter, "No Monitor" after upgrading to .NET 4.6.2


#1

Purchased a Plugable USB to VGA Video Graphics Adapter for Multiple Displays up to 1920x1080 (Supports Windows 10, 8.1, 8, 7, and XP) to connect a small (800x600) color screen via USB to VGA on a multi-monitor system (i2700k) using an NVIDIA 670 GPU. Worked fine until I needed to upgrade to .NET 4.6.2 and now the monitor is not recognized under Windows 7 “Screen Resolution”. Just says “No Monitor”. Tried installed latest driver for the device but no joy. Any ideas?


#2

Hello Keith,

Thanks for the post! I’m sorry to hear you’re having an issue with your adapter, but lets see if I can get you taken care of. The first thing I’d like to try is to perform a ‘clean’ install of the DisplayLink driver used by our products to ensure that is in a good state and not contributing to the problem. If you would, please follow these steps:

  1. Disconnect the adapter from the system. Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.0 M3 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the adapter to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

If that helps get the device working properly, great! If not, let me know and we’ll take it from there.

Thank you!


#3

Thanks Raul,

I followed your instructions and same result. I did however, get a notice from DisplayLink stating that my USB 3.0 host controller may not be compatible with the Plugable device. I have the device plugged into a USB 2.0 socket (black).

Keith


#4

I should also add that when I test the monitor in Screen Resolution the device driver shows as Generic PnP.


#5

Hello Keith,

Thank you for the information. I’m sorry the clean install didn’t work for you, but I’m not giving up. If it’s ok with you, I’d like to get a little bit more information. We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the device into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

I’ve created a ticket for your issue, so once you get that file you can email it to support@Plugable.com and use “Ticket 165993” in the subject line so we can match everything up. I will then limit our conversation to the direct email thread to keep everything in one place and then update this forum thread with what we may find.

Thanks!


#6