USB to serial with Garmin eTrex Vista GPS


#1

Hi,

I’ve installed the drivers as suggested and tested that the device is present using the

kexstat | grep prolific

and

ioreg -c IOSerialBSDClient | grep usb

and I can see the device.

Trouble is I still can’t communicate with the GPS. I get an error message from GPS Babel saying:

ERROR] GPS_Packet_Read: Timeout. No data received.
GARMIN:Can’t init /dev/cu.usbserial

I realise this isn’t a GPS forum but any idea if it’s likely to be the GPS or the serial adapter?

Interestingly I can connect to the GPS using the serial adapter if I run Windows XP as a virtual machine in VMWare fusion. It’s kind of a clunky way of doing what I want to do and I’d really like to have it working directly through the Mac OS.

I’m running OS X 10.8.2

Any help would be greatly appreciated.


#2

Hi Mike,

Thanks for posting here, I’ll try to help. From what I can tell on the GPSBael site, Mountain Lion should be supported, although it is not listed as supported on the download link.

Assuming it is though, the next step is to verify that your USB to Serial installation is working correctly on your Mac. If you have another serial device, or another program to talk to your GPS you can verify that your serial setup is working and narrow it down to a GPSBabel setting or command option problem.

Here’s the Mac software available from Garmin:
http://www8.garmin.com/macosx/index.jsp

Because the cable and device can communicate on Windows XP, it’s likely we are dealing with a configuration issue – either on the OS X, 10.8.2 side or with GPSBabel itself.

I hope this helps, let me know how it goes.

Thanks,
Jerome.

Plugable Technologies


#3

Jerome,

Thanks for the response.

I used GPS Babel after the Garmin web based software failed to connect or recognise the device. Other users had some success with GPS Babel on similar setups.
I also tried the GPS options in Google Earth but that had the same outcome. It automatically cycles through the different usb ports (bluetooth, serial etc.) looking for the device but fails to connect. One plus point with the Babel software is that it does report what it’s trying to do and what the errors are occurring which I guess might help identify the problem.

OS X treats the serial device as if it’s a modem. You can set Baud rate but there are other parameters that are not available with that configuration screen that are available under windows. I was wondering if that was the problem.

I’ll keep looking and see if there are any answers.

Thanks,

Mike

Update - I’ve installed the windows versions of both Google Earth and GPS Babel in the virtual machine and they both communicate with the GPS. Presumably that narrows it down to an OS X issue?


#4

Hi Mike,

Thanks for the extra details and the update. It does look like an issue with the setup on OS X. In the advanced tab in the setting for the USB to Serial device, if you click on advanced, is it set to null modem? Also make sure the the speed is correct for your device.

If all that checks out and still no improvement, if would be useful to try connecting to another serial device other than the Garmin. Is that possible?

Also, please send your Amazon Order id to us at support@plugable.com

I hope this helps, let me know what you find.

Thanks,
Jerome.


#5

Try using loadmytracks – settings are Garmin Serial (not usb!) and UsbSerial. I found this tip elsewhere and i’m able to use the Plugable USB to Serial adapter to successfully import/export waypoints, routes, tracks, and maps. From there I can do what I want with GPSBabel and GoogleEarth. Hope this helps.


#6

Hi cadamsfour,

Thanks for the details! It’s helpful to know what works for others!

Happy Holidays,
Jerome.


#7