usb to serial - how to enable a com port in wine


#1

I am unable to get my usb to serial working on Ubuntu 10.04. If I run lsusb, I see it, but I cannot get it working from wine. Any help will be most appreciated.


#2

Hi bnasuti,

Thanks for your post about using the Plugable USB to Serial cable with Ubuntu 10.04 and WINE.

First, make sure the cable is set up correctly in Ubuntu using a terminal program like minicom and another serial device. We’ll be happy to help with this if you want, just let us know!

Once its set up properly on the host, there are a few configuration steps necessary to tell WINE where to look for the serial port.

Because COM1 defaults to /dev/ttyS0 you’ll need to change the device to reflect the correct ttyUSB device. To find out which one that is, use a command like:

dmesg | grep tty

Then, create a symbolic link in the .wine/dosdevices directory that points to the correct /dev/ttyUSB from the dmesg output above. Here’s an example

ln -s /dev/ttyUSB0 com1

That’s all that’s required for PUTTY, you configure it as usual to use COM1 or which ever COM # you assigned above, other programs may differ.

Here’s a link with more detailed information:
http://wiki.jswindle.com/index.php/Ad…

Let me know how it goes, and if it’s not working post details of your setup like the program you are using, and the device or program you are connecting to.

I hope that does the trick!
Jerome Myers

Plugable Technologies

Here’s a link with some good instructions on setting up the


#3

Thanks for the pointers, I was able to get it working. for me the trick was to fully resolve the path like this: ln -s /dev/tty/USB0 ~/.wine/dosdevices/com1

I am very happy as I was able to get my ham radio interfaced to my computer! Thanks again for the help.


#4

Hi bnasuti,

That’s great news, I’m glad to hear you have your set up working!
Thanks for letting us know your outcome!

Enjoy,
Jerome.


#5

Hello

I have been trying to establish a connection from my Mac running Mountain Lion, through Wine. I tried typing dmesg | grep tty and got nothing. What am I doing wrong?

Thanks


#6

Jason,

In a terminal window, please run:

ls -l /dev/tty.*

This should list the mounted tty devices. If you cannot see any, ensure you have the right driver installed for the hardware in use.


#7