USB to Serial Adapter - OSX Lion(10.7.2) Driver Issue


#1

I am running OSX Lion 10.7.2 and am having issues with the driver being recognized by the OS. The driver is visible in System Profiler under USB Serial, but when I go to verify the driver is loaded, it is not there. kextstat | grep profiler, ioreg -c IOSerialBSDClient | grep usb and an ls tty.usb* from the /dev directory returns nothing. I have downloaded and installed the latest Prolific driver DMG package twice.

Any thoughts?

Thanks in advance


#2

Hi Greg,

Thanks for posting your question here. We’ll be happy to help. First, reboot your mac to be sure all of the USB ports are active. Macs sometimes disable USB ports until the next reboot if there’s been problems. Next, if it’s still not showing up, I’d like you to try moving the USB to Serial adapter to a different USB port.

Following the directions here:
http://plugable.com/2011/07/12/instal…

Can you say what happens when the installer finishes? Does it report any errors or do you get the “Installation Sucessfull” message?

The following command is actually looking for the prolific driver, so it should read:

kextstat | grep prolific

Double check that you have it correct.

Then run the

ioreg -c IOSerialBSDClient | grep usb

You should see the device. if you’re not able to see it at that point, is it possible to test the device in another machine? Also verify that the USB port on the Mac is functional by testing it with a simple USB device like a mouse.

Thanks for your patience,
Let us know how it goes, and we’ll figure out next steps,

Thanks,
Jerome.


#3

Did you ever get this working?
I’m considering purchasing the USB to Serial Adapter, and need it to work on a Mac running Lion OSX 10.7.3.
Thanks,
Vince


#4

Hi vrvann,

Thanks for checking. You’ll be able to use the Plugable USB to Serial adapter with Mac OS X 10.7.x. Just follow the instructions at the following link to get the drivers installed.

http://plugable.com/2011/07/27/howto-…

Thanks!
Jerome.


#5

Hi Jerome,

I’m stuck trying to get the USB to Serial to connect to my HP switch. I’ve verified that typing ioreg -c IOSerialBSDClient | grep usb gives me this:

| | | | “IOTTYBaseName” = “usbserial”
| | | | “IOCalloutDevice” = “/dev/cu.usbserial”
| | | | “IODialinDevice” = “/dev/tty.usbserial”
| | | | “IOTTYDevice” = “usbserial”

But then when I open GoSerial I can’t seem to get a connection. I’ve attached screenshots of the GoSerial window as well.

Looks like you’ve been helpful in your other posts. I’m hoping for the same for mine.

Thanks in advance!

Jason
!](https://d37wxxhohlp07s.cloudfront.net/s3_images/888689/Screen%20Shot%202013-04-17%20at%203.32.51%20PM_inline.png?1366227171)](https://d37wxxhohlp07s.cloudfront.net/s3_images/888689/Screen%20Shot%202013-04-17%20at%203.32.51%20PM.png?1366227171) !](https://d37wxxhohlp07s.cloudfront.net/s3_images/888691/Screen%20Shot%202013-04-17%20at%203.33.02%20PM_inline.png?1366227183)](https://d37wxxhohlp07s.cloudfront.net/s3_images/888691/Screen%20Shot%202013-04-17%20at%203.33.02%20PM.png?1366227183)


#6

Hi Jason,

Thanks for posting, I’ll be happy to help. What do you see when you run this command?

kextstat | grep prolific

Also, what happens if you run screen and connect to the usb to serial cable?

ie: screen /dev/cu.usbserial

Let me know these details and we’ll figure out the next step.

Thanks,
Jerome.


#7

Hi Jerome,

Thanks for the quick response.

I was actually able to get the serial to connect. The only issue now appears to be the garbled characters that spew out. I’ve tried changing the baud rates from 9600, 115200 etc. and there is slight improvements, but I’ve yet to find a baud rate that will properly display my keyboard inputs. For example, it seems 115200 will show the login screen fine, but as soon as I type anything, it appears as #&*(*&(! etc. I’ve tried using the same settings that I use on a PC to connect… No luck.

Your suggestions are much appreciated!

Thanks Jerome!

Jason


#8